Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с задачей!

10-11 класс

напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора(целое количество минут)— 3 День недели(1-понедельник,...7-воскресенье)--5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля)!

Al2307 05 окт. 2014 г., 20:33:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AisAis
05 окт. 2014 г., 22:55:25 (9 лет назад)

program D1KPxx3;
uses crt;
var
i:integer;
min,rez:real;
b:char;
label 1,2;
begin
1:write('Введите время разговора');
read(min);
writeln('Введите номер дня недели');
read(i);
if (i=6) or (i=7) then
begin
rez:=((min*5.52)-(min*0.2));
write('Стоимость разговора с учетом скидки равна: ',rez);
goto 2;
end
else
rez:=min*5.52;
write('Стоимость разговора равна: ',rez);
2:writeln('Ещё??  Y/N');
readln(b);
if b='Y' then
goto 1;
if b='N' then
write('Пока!');
end.

+ 0 -
VaiperRK
06 окт. 2014 г., 1:11:41 (9 лет назад)

Комментарий удален

+ 0 -
Yulkoo
06 окт. 2014 г., 3:44:20 (9 лет назад)

Комментарий удален

+ 0 -
Voroninasonya
06 окт. 2014 г., 5:12:39 (9 лет назад)

Вроде, там про этого не чего не сказано...но я думаю за 1 мин

Ответить

Другие вопросы из категории

дан фрагмент программы:

m:=14
n-m-3
m:n+m
write (m,n);
какие числа будут выведены на экран?

Для кодирования букв А, Б, В, Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11, соответственно). Если таким

способом закодировать последовательность символов ГБАВ и записать результат в шестнадцатеричной системе счисления, то получится:

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.

Здравствуйте) помогите составить задачи по паскалю)

задачи на такую тему: Составление, ввод, трансляция и
исполнение программ, реализующих
циклические алгоритмы и типовые
операции с одномерными массивами

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.



Вы находитесь на странице вопроса "Помогите с задачей!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.