Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят плз помогите решить задание номер 34, дело жизненной важности...TurboPascal плз парни спасааааайтееееееее молю ваааас юные айтишники...

10-11 класс

Alani1979 17 окт. 2014 г., 5:04:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Edinorozek
17 окт. 2014 г., 6:31:57 (9 лет назад)

var
    a:array[1..100,1..100] of integer;
   i,j,n,m:integer;
begin
  read(n,m); {количество строк и столбцов}
  for i:=1 to n do
   for j:=1 to m do
    if (i mod 2=1) then a[i,j]:=(i-1)*m+j else a[i,j]:=i*m-j+1; {заполнение}
 for i:=1 to n do
   begin
    for j:=1 to m do
     write(a[i,j]:4);  {вывод на экран}  
  writeln;
   end;
  readln
end.

+ 0 -
КАТЮШАКАТЯ
17 окт. 2014 г., 7:38:09 (9 лет назад)

я хоть и не парень но держи ответ

Ответить

Другие вопросы из категории

Разработать программу в Gambas.
Помогите с задачей!

напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора(целое количество минут)— 3 День недели(1-понедельник,...7-воскресенье)--5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля)!

дан фрагмент программы:

m:=14
n-m-3
m:n+m
write (m,n);
какие числа будут выведены на экран?

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить задание С2 из Егэ

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значение от -1000 до 1000.Гарантируется, что последний элемент массива отличен от нуля.
Приведите фрагмент программы вместо ... на языке Паскаль.
const N=30;
var
a: array [1..N] of integer;
i, x, y: integer;
s: real;
begin
for i;=1 to N do readln(a[i]);
.......
end.
ниже скрин задания.

помогите решить задание

ответ будет 9
мне решение надо, я разобраться не могу



Вы находитесь на странице вопроса "Ребят плз помогите решить задание номер 34, дело жизненной важности...TurboPascal плз парни спасааааайтееееееее молю ваааас юные айтишники...", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.