Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится некоторое количество (n) целых чисел. Найти среди них количество отрицательных чисел

10-11 класс

Skorik28 10 апр. 2014 г., 18:54:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shork
10 апр. 2014 г., 20:04:11 (10 лет назад)

var a,k,n:integer;
begin
readln(n);
for n:=n downto 1 do begin
read(a);
if a<0 then inc(k);
end;
writeln(k);
end.

Ответить

Другие вопросы из категории

Составить таблицу истинности, построить функциональную схему для

логической функции F и определить истинность формулы F = Bv(C& ¬A)v(A&B)

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

вычислите произведение всех целых чисел, расположенных за минимальным значением.

нужна программа для open office
как объяснила мне препод: вводишь произвольное количество чисел(допустим 6 чисел), с помощью формулы "min" вычислить минимальное... и нужно перемножить все числа расположенные после этого минимального числа)
например: 2 3 0 6 7 8 min=0
и нужно по какой-то функции перемножить числа 6 7 8
и если 0 поставить в другое место, числа после 0 все также перемножались)

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать алгоритм для X=5 и Y=-11.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное

среди них.Ничего кроме этого программа выводить не должна. При использовании системы Free Pascal для представления целых чисел используйте тип LongInt. Надо сделать в Pascal



Вы находитесь на странице вопроса "Вводится некоторое количество (n) целых чисел. Найти среди них количество отрицательных чисел", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.