Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача на паскале.

5-9 класс

Заданы 2 числа. Определить, какое из них встречается в массиве чаще.

(нужно полное решение)

Iliyaska 10 янв. 2017 г., 2:09:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angel3
10 янв. 2017 г., 4:23:25 (7 лет назад)

const max=10;
var
mas:array[1..max] of integer;
a,b:integer;
countA,countB:integer;
i:integer;
begin
readln (a,b);
for i:=1 to max do
begin
readln (mas[i]);
if (mas[i]=a) then countA:=countA+1;
if (mas[i]=b) then countB:=countB+1;
end;

if (countA>countB) then writeln ('Число' ,a,' встречается больше');
if (countB>countA) then writeln ('Число' ,b, ' встречается больше');
end.

Ответить

Другие вопросы из категории

1.Выполните на компьютере программу Еvklid. Протестируйте ее на значениях М= 32, N = 24; М = 696, N = 234.

2.Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу:А × В = НОД(А, В) × НОК(А, В).

Какое значение получит переменная у после выполнения фрагмента алгоритма?

х:=1
у:=2*х
у:=у+3
у:=у*х
у:=у+4
у:=у*х
у:=у+5
Восстановите формулу вычисления у для произвольного значения x

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

1)Как можно описать на Паскале 1)Как можно описать на Паскале массив,в котором будет храниться значения численности населения Москвы к концу

каждого года XX века?
2)Вы приобрели котёнка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будет храниться значения веса котёнка в течение месяца (например,мая)?

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!



Вы находитесь на странице вопроса "Задача на паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.