Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Выведите на экран все двузначные числа, которые при возведении в квадрат дают палиндром.

10-11 класс

Bednov2003 02 февр. 2017 г., 19:40:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anechkka
02 февр. 2017 г., 21:00:00 (7 лет назад)

var n,i:longint;
function polin(n:longint):boolean;
var i,j:longint;
s:string;
itog:boolean;
begin
itog:=true;
str(n,s);
if length(s)=1 then itog:=false;
for i:=1 to length(s) do begin
j:=length(s)-i+1;
if s[i]<>s[j] then itog:=false; end;
polin:=itog;
end;
BEGIN
n:=99;
writeln('Chisla: ');
for i:=1 to n do
if polin(i*i) then
writeln(i,' (',i*i,')');
end.

Ответить

Другие вопросы из категории

Нужно написать программу в паскале.

На вход поступает некое целое число икс(х).Х принадлежит промежутку (-30000;30000)
Если Х четное и делится на 5 то выводится соответствующая надпись.Если нет- надпись не выводится

Составить программу нахождения первых чётных чисел от 1 до 20.

Помогите, пожалуйста!

помогите с информатикой

Читайте также

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то

выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

Плиз помогите с информатикой( в башке заело) ( здесь нужно использовать циклы for while или repeat);заранее спасибо)

1)Натуральное число n называется простым если оно делится только на 1 и на само себя.по соглашению 1 не считают простым числом. Проверить является ли n простым числом

2)Найдите и выведите на экран все трехзначные числа кратные 3, сумма цифр которых больше суммы цифр частного от деления их на 3

Дано целое число k (1<=k<=180) и последовательность цифр 10111213...9899, в которой выписаны подряд подряд все двузначные числа. Определить

двузначное число, образованное парой цифр, в которую входит k-я цифра;
Примечание: величины строкового типа не использовать.

p.s объясните само задание, пожалуйста. Решение есть на яндексе.



Вы находитесь на странице вопроса "Выведите на экран все двузначные числа, которые при возведении в квадрат дают палиндром.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.