Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Создайте блок-схему к задачи:

10-11 класс

Выделить положительные числа в одномерном массиве, создав новый массив.

Tinftgtd 20 янв. 2015 г., 10:43:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Veresotsky
20 янв. 2015 г., 12:42:29 (9 лет назад)

var
  i, j, n, np, l: integer;
  a, b: array[1..100] of integer;

begin
  Randomize;
  n := 50; l := 30;
  for i := 1 to N do
  begin
    a[i] := -n + Random(100);
    write(' ', a[i]);
  end;
  Writeln;
  Writeln('Массив положительных элементов');
  j := 0;
  for i := 1 to l do
    if a[i] > 0 then begin
      j := j + 1;
      b[j] := a[i];
      Write(b[j]:3)
    end;
  np := j;
  Writeln;
  Writeln('Массив содержит ', np, ' положительных элементов')
end.

Тестовое решение:

 41 -15 1 -16 4 -33 -2 40 21 -17 3 -50 -15 25 1 -41 -19 27 -36 -42 11 -34 30 -15 31 -3 17 -22 -47 -21 -11 -33 -8 2 -32 12 -27 15 -41 -5 22 -42 -21 36 -16 37 -17 -46 -26 -8
Массив положительных элементов
 41  1  4 40 21  3 25  1 27 11 30 31 17
Массив содержит 13 положительных элементов


Ответить

Другие вопросы из категории

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

Создать блок схему для следующей задачи (разветвленный алгоритм): Ввести с клавиатуры число (любое). Если число положительно, то нарисовать круг. Если

отрицательное или равно 0 - закрашенный прямоугольник помогите плиз написать программу для QBASIC

Задание № 1) Разработать блок схему алгоритма, который проверяет, является ли четным введенное с клавиатуры число

Задание 2) Разработать блок схему алгоритма? для вычисления и вывода на экран суммы 5 случайных числе в диапазоне 0..36.



Вы находитесь на странице вопроса "Создайте блок-схему к задачи:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.