Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задание 2. Создайте файл информации по итогам сессии result.dat. Для каждой группы каждого курса в файл заносится информация(количество курсов и

10-11 класс

групп на курсе фиксировано, сами номера курсов и групп в записи не хранятся):

Xenia80 18 сент. 2014 г., 6:27:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dina122
18 сент. 2014 г., 7:04:58 (9 лет назад)

Будем создавать файл, допускающий впоследствии поиск.

type
RC=record
Kol:integer;
Dop:integer;
Kol5:integer;
Kol43:integer;
Kol2:integer
end;
var r:RC;
f:file of RC;
begin
Assign(f,'result.dat');
Rewrite(f);
repeat
  Readln(r.Kol,r.Dop,R.Kol5,r.Kol43,r.Kol2);
  if r.Kol>0 then
     write(f,r);
  until r.Kol=0;
Close(f)
end.

Ответить

Другие вопросы из категории

Помогите плиз

Задан массив Х(50). Переписать в массив У элементы массива Х в обратном порядке

Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи,задавая комбинацию точек и тире.Сколько различных символов(цифр,букв,знаков

пунктуации и т.д)можно закодировать,используя код Морзе длиной ровно в пять сигналов(точек и тире)?напишите по подробнее

Читайте также

1. Расширение файла, как правило, характеризует:

тип файла

программное обеспечение

название программы

2. Файл - это:

поименованный объект, расположенный на диске

поименованная совокупность байтов, размещенная на внешнем носителе

совокупность поименованных ячеек памяти

3. Задан полный адрес файла: c:\documets\prikaz.doc. Какое у файла составное имя?

prikaz.doc

documets\prikaz.doc

documets\prikaz

^ 4. К сервисным системам относятся:

интерфейсные системы

инструментальные системы

утилиты

программные системы

оболочки

^ 5. Какое программное обеспечение обеспечивает рабочую среду для других программ:

прикладное

системное

инструментальное

^ 6. Какая версия программного продукта является более новой:

MS DOS 6.0

MS DOS 6.20

MS DOS 6.22

7. Программы, скачанные из Интернета и имеющие определенный срок пользования, являются:

платными

бесплатными

условно-бесплатными

^ 8. Интерфейс, в котором для управления компьютером используются объекты, называется:

объектно-ориентированным

графическим

командным

^ 9. Программы, которые существенно меняют пользовательский интерфейс, не меняя при этом программный, относятся к:

утилитам

интерфейсным системам

оболочкам

^ 10. Какой шаблон позволяет найти файлы, которые начинаются на букву f, заканчиваются на t и имеют любое расширение:

*f????t.*

f*?d.*??

f?*d.*

^ 11. Сколько различных операционных систем можно установить на одном жестком диске:

только одну

только две

только три

12. Какое максимальное число логических дисков можно создать в расширенном разделе:

три

любое

23

13. После форматирования диска его доступный объем может уменьшиться по причине:

наличия на диске логических ошибок

наличия испорченных секторов

наличия фатальных ошибок

1. Информацию, существенную и важную в настоящий момент, называют: 1) полной; 2) полезной; 3) актуальной; 4 )достоверной

.

2. Тактильную информацию человек получает посредством:

1) специальных приборов;

2) органов осязания;

3) органов слуха;

4) термометра.

3. Обмен информацией – это:

1) выполнение домашней работы;

2) просмотр телепрограммы;

3) наблюдение за поведением рыб в аквариуме;

4) разговор по телефону.

4. За единицу количества информации принимается:

1) 1 байт;

2) 1 бит;

3) 1 бод;

4) 1 см.

5. Компьютерные вирусы:

1) возникают в связи сбоев в аппаратной части компьютера;

2) имеют биологическое происхождение;

3) создаются людьми специально для нанесения ущерба ПК;

4) являются следствием ошибок в операционной системе.

6. Алгоритм – это:

1) правила выполнения определенных действий;

2) набор команд для компьютера;

3) протокол для вычислительной сети;

4) описание последовательности действий, строгое исполнение которых приводит к решению поставленной задачи за конечное число шагов.

7. Свойство алгоритма, заключающееся в отсутствии ошибок, алгоритм должен приводить к правильному результату для всех допустимых входных значений, называется:

1) результативность;

2) массовость;

3) дискретность;

4) конечность.

8. Свойство алгоритма, заключающееся в том, что один и тот же алгоритм можно использовать с различными исходными данными, называется:

1) результативность;

2) массовость;

3) конечность;

4) детерминированность.

9. Текстовый редактор – программа, предназначенная для:

1) создания, редактирования и форматирования текстовой информации;

2) работы с изображениями в процессе создания игровых программ;

3) управление ресурсами ПК при создании док3ументов;

4) автоматического перевода с символьных языков в машинные коды.

в глобальной компьютерной сети протокол IP обеспечивает:

1.передачу информации по заданному адресу;
2.разбиение передаваемого файла на части;
3.получение почтовых сообщений;
4.передачу почтовых сообщений;

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.



Вы находитесь на странице вопроса "Задание 2. Создайте файл информации по итогам сессии result.dat. Для каждой группы каждого курса в файл заносится информация(количество курсов и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.