Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколь

10-11 класс

ко нулей. Разработать для программы не менее двух тестов и доказать правильность её работы.

Didnken 28 июня 2013 г., 13:05:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Динок99
28 июня 2013 г., 14:31:08 (10 лет назад)

program ms3o1; {пишу по памяти-не судите строго за ошибки}

var n,i,j,p,o,n:integer;

begin

n:=0; {тут у нас будут ноли}

o:=0;{тут отрицательные}

p:=o;{и тут соответственно положительные}

writeln('Введите кол-во целых чисел для проверки');readln(n);

for i:=1 to n do

begin

writeln('Введите число: ');readln(j);

if j=0 then n:=n+1;

if j>0 then p:=p+1;

if j<0 then o:=o+1;

end;

writeln('Отрицательных: ',o);

writeln('Положительных: ',p);

writeln('Равны ноль: ',n);

readln;

end.

Ответить

Другие вопросы из категории

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

. Зарплата менеджера составляет 200$ + процент от продаж. продажи до 500$ - 3%, от 500 до 1000 – 5%, свыше 1000 – 8%. Пользователь вводит с клавиатуры

уровень продаж для трех менеджеров. Определить их зарплату, определить лучшего менеджера, начислить ему премию 200$, вывести итоги на экран.

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное

среди них.Ничего кроме этого программа выводить не должна. При использовании системы Free Pascal для представления целых чисел используйте тип LongInt. Надо сделать в Pascal



Вы находитесь на странице вопроса "Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколь", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.