Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

пример длинного линейного алгоритма по информатике плиззз срочно, буду благодарен

5-9 класс

Smirn2002com 03 мая 2013 г., 6:57:12 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Андрей2812
03 мая 2013 г., 9:45:32 (11 лет назад)

Достаточно длинный?)

var a: array [0..30] of integer;
    i, o: integer;
    s: string;

begin
     for i := 1 to 30 do
     begin
          a[i] := random(6) - 3;
     end;

     writeln('Массив:');
     for i := 0 to 30 do
     begin
         writeln('[', i, '] => ', a[i]);
         if (a[i] > 0) then
         begin
              o := o + a[i];
              s := s + inttostr(i) + ' ';
         end;

     end;

     writeln('Номера положительных чисел: ', s);

end.

Ответить

Другие вопросы из категории

5) Производится двухканальная (стерео) звукозапись с частотой дискретизации 48 кГц и глубиной кодирования 24 бита. Запись длится 1 минуту, ее

результаты записываются в файл, сжатие данных не производится. Какое из приведенных ниже чисел наиболее близко к размеру полученного файла, выраженному в мегабайтах?

У исполнителя Делитель две команды, которым присвоены номера:

1. раздели на 2
2. вычти 1
Первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1.
Исполнитель работает только с натуральными числами.
Составьте алгоритм получения из числа 65 числа 4, содержащий не более 5 команд. В ответе запишите только номера команд.
(Например, 12112 – это алгоритм:
раздели на 2
вычти 1
раздели на 2
раздели на 2
вычти 1,
который преобразует число 42 в число 4).
Если таких алгоритмов более одного, то запишите любой из них.

Помогите, пожалуйста.

Составьте алгоритмы и напишите программы для решения задач: 1. Вводятся два числа. Если первое число больше второго, то напечатать их сумму, иначе напечатать их разность 2. Вводятся значения двух ЦИФР. Напечатать максимальное двузначное число, которое можно сформировать из этих цифр или сообщение, что таких двухзначных чисел не существует. 3. Вводится последовательность N чисел.Определите, каких чисел в последовательности больше: кратных 5 или нечетных.

Читайте также

Помогите срочно! По информатике задали 7 вопрос: Возле школы растут шесть деревьев: сосна, берёза, липа, тополь, ель и клён. Какое из этих деревьев самое

низкое, если известно, что берёза ниже тополя, липа выше клёна, сосна ниже ели, липа ниже берёзы, сосна выше тополя?
И второй вопрос: Пятеро одноклассников - Аня, Саша, Лена, Вася и Миша - стали победителями школьных олимпиад по истории, математике, информатике, литературе и географии. Известно, что: 1) победитель олимпиады по информатике учит Аню и Сашу работе на компьютере; 2) Лена и Вася заинтересовались информатикой; 3) Саша всегда побаивался истории; 4) Лена, Саша и победитель олимпиады по литературе занимаются плаванием; 5) Саша и Лена поздравили победителя олимпиады по математике; 6) Аня сожалеет о том. что у неё остаётся мало времени на литературу.
Победителем какой олимпиады стал каждый из этих ребят?

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

Помогите!!!!очень нужно))паскаль. паскаль. 1)известны оценки по информатике каждого из 20 учеников класса. В начале списка перечислены все пятерки,

затем все остальные оценки. Сколько учеников имеют по информатике оценку пять?Условный оператор не использовать. 2)Составить программу, которая находит минимальное число большее 200, которое нацело делится на 17. Использовать цикл с предусловием While.всю программу напишите, пожалуйста)))



Вы находитесь на странице вопроса "пример длинного линейного алгоритма по информатике плиззз срочно, буду благодарен", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.