Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан массив действительных чисел,размерность которого N.Подсчитать,сколько в нём отрицательных,положительных и нулевых элементов.

10-11 класс

Irinalog12312 21 окт. 2016 г., 16:10:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eri4kа
21 окт. 2016 г., 16:59:26 (7 лет назад)

Program n1;
Uses Crt;
Var
c: array[1..1000] of integer;
n, i, null, otric, polozhit :integer;
Begin
   writeln('Razmer massiva = '); Readln(n);

for i:=1 to n do begin
   c[i]:=random(40) - 20;
   write(c[i]:4);
end;

    writeln();

otric:=0; polozhit:=0; null:=0;
for i:=1 to n do  begin
   if (c[i]<0) then otric:=otric+1;
   if (c[i]>0) then polozhit:=polozhit+1;
   if (c[i]=0) then null:=null+1;
end;
   writeln('Kol-vo chisel < 0: ', otric);
   writeln('Kol-vo chisel > 0: ', polozhit);
   writeln('Kol-vo chisel = 0: ', null);
End.

Ответить

Другие вопросы из категории

Автомат получает на вход четырехзначное восьмеричное число. По этому числу строится новое число по следущим правилам 1. Складываются первая и вторая, а

также третья и четвертая цифры 2. Полученные два числа записываются другза другом в порядке возрастания( без разделителей) Пример 4531. Суммы 4+5=11; 3+1=4. Результат 411 Какое из следующих чисел является результатом работы автомата 1) 117 2) 1213 3) 1511 4) 1517 Если можно с решением) заранее спасибо)

Дан массив, содержащий 30 целых чисел. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на одном из языков программирования алгоритм,

позволяющий найти минимально трехзначное число, записанное в этом массиве. Если такого числа нет то нужно вывести сообщение об этом.



const
n=30;
var
a: array [1..n] of integer;
i, j, min: integer;
begin

Решить в СИ!

Даны три действительных числа. Возвести в квадрат и напечатать те из них, значения которых неотрицательны. Если таковых нет, то напечатать сообщение

Правильно ли составлена блок-схема?

Почему не k:=k+3?

Читайте также

дан массив действительных чисел,размерность которого N.

Подсчитать,сколько в нем отрицательных,положительных и нулевых элементов. Программа в паскаль

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "дан массив действительных чисел,размерность которого N.Подсчитать,сколько в нём отрицательных,положительных и нулевых элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.