Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста!!!

5-9 класс

Эвелина17 28 янв. 2017 г., 21:38:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ralifka
28 янв. 2017 г., 22:52:02 (7 лет назад)

Задача 1
var
a:array [1..20] of integer;
i,k:integer;
begin
randomize;
writeln('Массив:');
for i:=1 to 20 do
begin
a[i]:=random(60)-12;
write(a[i],' ');
end;
writeln;
for i:=1 to 20 do
if (a[i] mod 2)=0 then k:=k+1;
writeln('Количество четных элементов: ',k);
end.

Задача 2
var
a:array [1..10] of integer;
i,k:integer;
begin
a[1]:=-6; a[2]:=0; a[3]:=56; a[4]:=12; a[5]:=32;
a[6]:=44; a[7]:=32; a[8]:=56; a[9]:=-17; a[10]:=-9;
writeln('Массив:');
for i:=1 to 10 do
write(a[i],' ');
writeln;
k:=1;
for i:=1 to 10 do
if a[i]<0 then k:=k*a[i];;
writeln('Произведение отрицатльных элементов: ',k);
end.

Задача 3
var
a:array [1..12] of integer;
i,k:integer;
begin
a[1]:=-6; a[2]:=0; a[3]:=56; a[4]:=12; a[5]:=32;
a[6]:=44; a[7]:=32; a[8]:=56; a[9]:=-17; a[10]:=-9;
a[11]:=89; a[12]:=13;
writeln('Массив:');
for i:=1 to 12 do
write(a[i],' ');
writeln;
k:=0;
for i:=1 to 12 do
if a[i]>32 then k:=k+a[i];;
writeln('Сумма элементов больших 32: ',k);
end.

Задача 4
var
a:array [1..10] of integer;
i:integer;
begin
a[1]:=-6; a[2]:=0; a[3]:=56; a[4]:=12; a[5]:=32;
a[6]:=44; a[7]:=32; a[8]:=56; a[9]:=-17; a[10]:=-9;
writeln('Массив:');
for i:=1 to 10 do
write(a[i],' ');
writeln;
writeln('Массив после замены элементов: ');
for i:=1 to 10 do
if (a[i] mod 3)=0 then a[i]:=50;
for i:=1 to 10 do
write(a[i],' ');
writeln;
end.

Задача 5
var
a:array [1..5] of integer;
i,k:integer;
begin
randomize;
writeln('Массив:');
for i:=1 to 5 do
begin
a[i]:=random(168)-120;
write(a[i],' ');
end;
writeln;
k:=a[4];
a[4]:=a[5];
a[5]:=k;
writeln('Массив массив после перестановок:');
for i:=1 to 5 do
write(a[i],' ');
writeln;
end.


Ответить

Другие вопросы из категории

В каком файле может храниться рисунок?

text.bmp
command.com
test.exe
grafik.txt

Помогите пожалуйста,нужно составить программу (в паскаль):

1)Определить,делителем каких чисел a,b.c является число K.
2)Определите,является ли треугольник со сторонами a,b,c равнобедренным.

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.