Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается

10-11 класс

на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

2. Дано натуральное число

87788137348 31 дек. 2014 г., 16:51:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladimirovaari
31 дек. 2014 г., 19:01:00 (9 лет назад)

1)

int f(int x,int p, int y)

{int k=0;

while(x<y)

 {

   x=+p*x/100;

   k++; 

  }

 return k;

}

 

2)

int f(int A)

{int x=1, y=1, n=2;

 while(x<A || y<A)

{

if(x<y)

x=+y;

else

y=+x;

}

n++;

}

if(A=y || A=x )

return n;

else 

return -1;

}

Ответить

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Как исправить for на цикл while?????

var n,k,i,t:integer; f:text;
begin
assign(f,'f1.txt');
rewrite(f);
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(f,i:3);
end;
close(f);
end.

помогите решить задачку пожалуйста: Для хранения в растровом графическом файле изображения размером 640×1504 пикселей отвели 705 Кбайт памяти(без учёта

размера заголовка).Каково максимально возможное число цветов в палитре изображения?

Теплоход расчитан на a пассажиров и b членов комманды.Каждая спасательная шлюпка может вместить c человек . Какое наименьшее число шлюпок должно быть на

теплоходе чтобы в случае необходимости в них можно было разместить всех пассажиров и всех членов комманды (a=1000,b=30,c 50

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.



Вы находитесь на странице вопроса "решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.