Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, пожалуйста, решить задачу на Паскале.Строка содержит одно слово. Проверить, будет ли оно читаться одинаково справа

5-9 класс

налево и слева направо.

Golubak 06 окт. 2014 г., 6:58:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yakubovichilya
06 окт. 2014 г., 9:38:15 (9 лет назад)

program lena1PL;
var s:string;   
i,c:integer;
begin
readln(s);
for i:=1 to (length(s) div 2) do
if s[i]=s[length(s)-i+1] then inc(c,1)
else begin writeln('HET'); exit; end;
if c=(length(s) div 2) then writeln('DA');
end.

Ответить

Другие вопросы из категории

Читайте также

1)строка содержит одно слово. проверить будет ли оно читаться одинаково справа налево и слева направо.

2)В записке слова зашифрованы - каждое из них записано наоборот. Расшифровать сообщение.

Помогите, пожалуйста, решить задачу на паскале. Срочно.

Даны два натуральных числа m и n. (m,n ≤ 9999). Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n.

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите пожалуйста решить задачу на С++

Заполнить массив по следующему принципу:
31 25 19 13 7 1
32 26 20 14 8 2
33 27 21 15 9 3
34 28 22 16 10 4
35 29 23 17 11 5
36 30 24 18 12 6



Вы находитесь на странице вопроса "Помогите, пожалуйста, решить задачу на Паскале.Строка содержит одно слово. Проверить, будет ли оно читаться одинаково справа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.