Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать в виде программы!!! Даны 2 одномерных массива А(10) и В(10), диапазон: [-10;40]. В массиве А найти минимальнный элемент, в

10-11 класс

Массиве В каждый элемент увеличить на этот минимальный

Kote5345 11 февр. 2014 г., 22:43:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Niksherkasov
12 февр. 2014 г., 1:32:07 (10 лет назад)

Var a:array [1..10] of integer;

b:array [1..10] of integer;

i,min:integer;

begin

randomize;

min:=a[1];

 

for i:=1 to 10 do begin

a[i]:=random(40)-10;

if (a[i]<min) then min:=a[i];

 

end;

for i:=1 to 10 do begin

b[i]:=random(40)-10;

end;

for i:=1 to 10 do begin

b[i]:=b[i]+min;

writeln(b[i]);

end;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить

Читайте также

Тема паскаль:

Даны три массива A,B,C, состоящие из 10 элементов.Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.(4 стр, 10 столбцов, 0 до 10).Пожалуйста помогите кто умеет решать.Времени мало осталось.Заранее спасибо.
Например:
A B C D
1 2 3 (1+2+3)/3=2
2 3 4 (2+3+4)/3=3
3 4 5 (3+4+5)/3=4
4 5 6 (4+5+6)/3=5
5 6 7 (5+6+7)/3=6
6 7 8 (6+7+8)/3=7
7 8 9 (7+8+9)/3=8
8 9 10 (8+9+10)/3=9
9 10 11 (9+10+11)/3=10
10 11 12 (10+11+12)/3=11

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.



Вы находитесь на странице вопроса "Помогите написать в виде программы!!! Даны 2 одномерных массива А(10) и В(10), диапазон: [-10;40]. В массиве А найти минимальнный элемент, в", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.