Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив из n вещественных чисел. Найти среднее арифметическое число элементов.

5-9 класс

Daryalozovaya1 15 февр. 2017 г., 19:12:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Антон1225
15 февр. 2017 г., 21:57:13 (7 лет назад)

простейшая задача
#include <iostream>
using namespace std;
int main()
{
    int n,m,z;
    m = 0;
    z = 0;
    int a[10000];
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> a[n];
        m += a[n];
    }
    z = m / n;
    cout << z;
}

Ответить

Другие вопросы из категории

1)какие действия выполняет компьютерная мышь?

2)для чего используется компьютерное меню?
3)как называется ограниченная рамкой область экрана?
4)какие способы завершения есть?

Сделайте номер -

20 баллов

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.



Вы находитесь на странице вопроса "Дан массив из n вещественных чисел. Найти среднее арифметическое число элементов.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.