Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дмитрий отправляется в школу, которая находится в 1 км от его дома. Дойдя до школы, он вдруг вспоминает, что забыл дома тетради, и поворачивает

5-9 класс

назад. Пройдя полпути, он меняет своё решение, посчитав что лучше вернуться в школу до звонка на урок. Пройдя 1/3 км по направлению к школе, он вдруг осознаёт, что не прав и опять меняет направления движения, теперь прежде чем изменить решение, он проходит 1/4 км. Так он и продолжает метаться: после N-го этапа, пройдя 1/N км, снова меняет решение. Надо найти с точностью до 0, 0001 км расстояние от дома до места, где ученик остановился.

6660666 07 февр. 2017 г., 7:30:38 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
WowBoom
07 февр. 2017 г., 9:34:18 (7 лет назад)

Наблюдение 1: сумма ряда 1 - 1/2 + 1/3 - 1/4 + 1/5 -... известна и равна ln(2) ~ 0.693147..., так что ответ можно написать и так.
Наблюдение 2: если ряд знакочередующийся и его члены по модулю равномерно убывают (т.е. ряд имеет вид x1 - x2 + x3 - x4 + x5 -... и x1 > x2 > x3 > x4 > x5 > ... > 0), то отличие частичной суммы ряда x1 - x2 + x3 - ... +- xn от истинной не более, чем xn.

Используя наблюдение 2, приходим к выводу, что необходимо суммировать первые 10000 членов ряда.

var S: real;
  i: integer;
begin
  S := 0;
  for i := 1 to 10000 do
    if (i mod 2 = 1) then
      S := S + 1/i
    else
      S := S - 1/i;
  writeln(S)
end.

Ответить

Другие вопросы из категории

Напишите в паскале.

1)Дан вес человека.Определить и вывести на экран, в какой весовой категории он окажется в боксе если; меньше 60 кг- легкий вес, от 60 до 75 средний вес, свыше 75 тяжелый вес.
2)Составить программу, которая спрашивает "Который час?" и в зависимости от ответа сообщает: "Доброй ночи","Доброе утро".Добрый день","Добрый вечер".

ваня учится в 1 классе и хорошо знает таблицу умножения но не знает английского языка.Какое из сообщений будет для Вани информитивным?

А)2*8=16

Б)MY FRIEND IS SCHOOLBOY

C)Ваня учится в школе

D)в английском алфавите 26 букв

E)6 MULTIPLAY 8 EQUAL 48

Читайте также

Дан одномерный массив B из N элементов, значения которых находятся в диапозоне от 0 до 325.

1) Заменить все чётные элементы на их номера. Вывести на экран исходный и новый массив.
2) Заменить все чётные элементы, стоящие на нечетных местах, на их номера.

Заполнить двухмерный массив С(5,6) целыми случайными числами, значения которых находятся в интервале от -8 до +9, выведет на экран массив в виде таблицы,

найдёт сумму всех отрицательных элементов массива и выведет результат на экран

Сколько в км от Суздаля до Москвы,от

Сколько в км
от Суздаля до Москвы,
от Владимира до Москвы
от Костромы до Москвы
от Гусь - Хрустальный до Москвы


ПЛИЗЗЗ ПОБЫСТРЕЕ!

Помогите пожалуйста!!! Ответьте на вопросы которые можете!!!

1. Какие преимущества обеспечивают табличные информационные модели по сравнению со словесными описаниями? Приведите пример.
2. Любое ли словесное описание можно заменить табличной информационной моделью? Приведите пример.
3. Приведите примеры табличных информационных моделей с которыми вы встречались на уроках в школе.
4. Приведите примеры табличных информационных моделей с которыми вы встречались в повседневной жизни.
5. Каких правил следует придерживаться при составлении таблиц?
6. Информация каких видов размещается в столбцах таблицы?
7. К какому типу относится "Табель успеваемости", расположенная в конце дневника.
8. Приведите примеры таблицы ОС
9. Приведите примеры таблицы ООО
10. В какой жизненной ситуации могут оказаться полезными вычислительные таблицы? Приведите предмет.
11. На что следует обращать внимание при заполнении итоговой строки (столбца)
12. Приведите примеры двух классов, объекты которых находятся в отношении взаимно однозначного соответствия.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Дмитрий отправляется в школу, которая находится в 1 км от его дома. Дойдя до школы, он вдруг вспоминает, что забыл дома тетради, и поворачивает", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.