Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составить программу

10-11 класс

чтобы удалить все гласные из строки , помогите пожалуйста,очень срочно нужно!!!!!!

Felbhdjctvm 06 апр. 2015 г., 1:23:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
НеМногоНеЗнаю
06 апр. 2015 г., 3:36:53 (9 лет назад)

program BezGlasnix;
var
i: Byte;
Stroka, Buffer: String;
begin
// 4itaem stroku.
Write('Vvedite stroku:');
ReadLn(Stroka);

//
Buffer:='';

//
for i:=1 to Length(Stroka) do
if (Stroka[i] <> 'a') and (Stroka[i] <> 'e') and (Stroka[i] <> 'i') and (Stroka[i] <> 'o') and (Stroka[i] <> 'u') and (Stroka[i] <> 'y') then Buffer:=Buffer + Stroka[i];

//
Stroka:=Buffer;
// Vvivod stroki.
Write('Stroka bez glasnix: '+Stroka);
end.

Дешево и сердито :)














+ 0 -
Myerftwer
06 апр. 2015 г., 5:19:06 (9 лет назад)

program GetStringWithoutVowels;
var i : integer;
    inputStr : string;
    outputStr : string;
    symbol : char;
begin
    //Readln(inputStr);
    inputStr := 'HELLO, world!';
    for i := 1 to Length(inputStr) do
    begin
        symbol := LowerCase(inputStr)[i];
        if (symbol <> 'a') and (symbol <> 'e') and (symbol <> 'i')
            and (symbol <> 'o') and (symbol <> 'u') and (symbol <> 'y')
        then outputStr := outputStr + inputStr[i];
    end;
    Writeln(outputStr);
    Readln();
end.

+ 0 -
Elmira961
06 апр. 2015 г., 7:31:24 (9 лет назад)

я значит лучше тебя ^^

+ 0 -
Nipple
06 апр. 2015 г., 9:16:56 (9 лет назад)

but you не расстраивайся please

+ 0 -
Mishagrinberg
06 апр. 2015 г., 11:50:30 (9 лет назад)

Конечно бро, давай на asm'e ему напишем ;)

+ 0 -
абремедвекос
06 апр. 2015 г., 13:25:06 (9 лет назад)

:|

+ 0 -
Bondarevaiulya
06 апр. 2015 г., 14:30:35 (9 лет назад)

Пусть еще приз за оптимизацию возьмет :)

Ответить

Другие вопросы из категории

Дана матрица А(п, п).

Составить блок-схему нахождения суммы
элементов, принадлежа­щих вспомогательной
диагонали матрицы.

С дано пожалуйста.

Для записи сообщения использовался 64-х символьный алфавит.каждая страница содержит 30 строк.все сообщение содержит 8775 байтов информации и занимает 6
страниц.сколько символов в строке?

Задание на картинке, в паскалеABC.

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".



Вы находитесь на странице вопроса "составить программу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.