Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

в массиве А(20),диапазон: [-10 ; 30] посчитать количество элементов кратных 3 и каждый элемент увеличить на это количество.

10-11 класс

Помоги, пожалуйста!)

Adele17 20 сент. 2016 г., 20:39:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
K071998
20 сент. 2016 г., 23:06:40 (7 лет назад)

Program Pr1;
uses crt;
var mas:array[1..20] of integer;
i,a:integer;
Begin
clrscr;
a:=0;
randomize;
for i:=1 to 20 do begin
mas[i]:=-10+random(41);
write(mas[i],' ');
end;
for i:=1 to 20 do if mas[i] mod 3=0 then a:=a+1;
for i:=1 to 20 do if mas[i] mod 3=0 then mas[i]:=mas[i]+a;
writeln();
for i:=1 to 20 do write(mas[i],' ');
end.

Ответить

Другие вопросы из категории

на плоскости заданы своими координатами n точки. составить программу , определяющую между какими из пар точек самое большое рассотяние . Указание

координаты точек занести в массив. Одну из частей подпрограммы оформить процедурой или функцией.паскаль

Дан год. Вывести на экран название животного, символизирующего заданный

год по восточному календарю. Выполнить надо желательно с оператором case.

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы



Вы находитесь на странице вопроса "в массиве А(20),диапазон: [-10 ; 30] посчитать количество элементов кратных 3 и каждый элемент увеличить на это количество.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.