Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность

10-11 класс

максимального и минимального

в) максимальный элемент из стоящих на четных местах

г) сумму положительных и среднее арифметическое отрицательных

д) второй максимум

е) длину наибольшего фрагмента, состоящего из одинаковых элементов.

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))

Nastenapas 06 янв. 2014 г., 15:29:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pol34kol
06 янв. 2014 г., 16:50:56 (10 лет назад)

a)

program name;
var a,b,c:integer;
begin
c:=0;
readln(a,b);
If (a>b+c) then writeln('Наибольшее число: ' , a)
else if (a<b+c) then writeln('Наибольшее число: ' , b)
else write();

readln();  // взависимости от компилятора.
end.

 

Сейчас ещё что-нибудь решу!

 

Ответить

Другие вопросы из категории

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0

Читайте также

Задание звучит : Дана последовательность целых чисел, за которой следует ноль. Определить, число соседств чисел с одинаковыми знаками.

Что нужно изменить в программе, чтобы выполнялось условие задачи.

Program exapmle2;
var x,y,k:integer;
begin
writeln('Эта программа определяет, число соседств чисел с одинаковыми знаками');
write('Введите число:');
read(x);
y:=x;
k:=0;
while y<>0 do
begin
if x*y<0 then inc(k);
if x*y>0 then inc(k);
y:=x;
read(y);
end;
writeln(' Число соседств ',k);
writeln('нажмите Enter для завершения работы программы');
readln;
end.

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

33. Последовательность чисел

Вводится последовательность целых чисел, заканчивающаяся нулем. Преобразовывать последовательность следующим образом:

1) заменить отрицательные числа в последовательности на их модули и вывести получившуюся последовательность;

2) в полученной последовательности заменить четные числа на максимальное число последовательности, вывести результат;

3) в полученной последовательности вычесть из каждого члена последовательности 2, вывести результат;

4) в полученной последовательности заменить отрицательные на 0, вывести результат.



Пример.

Последовательность: 1 2 3 0

1) 1 2 3

2) 1 3 3

3) –1 1 1

4) 0 1 1



Вы находитесь на странице вопроса "ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.