Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны два различных числа. Составьте программу, которая заменяет наименьшее из двух чисел их суммой, а наибольшее их произведением.

5-9 класс

Помогите пожалуйста)

Oxalnov 16 апр. 2015 г., 11:37:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
95166
16 апр. 2015 г., 12:15:13 (9 лет назад)

var a,b,c,d:integer;
begin
   read(a,b);
   c:=a+b;
   d:=a*b;
   if a < b then begin
      a:=c;
      b:=d;
  end else begin
      a:=d;
      b:=c;
   end;
   write('a=',a,' b=',b);
end.

Ответить

Другие вопросы из категории

Программа на языке паскаль сравнить 2 числа а и б если число а>б, то тогда б=а2

если а=б, то без изменений
если а<б, то б=корень а

вот это нужно)решиить
Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам:

1. Вычесляются два числа - сумма первой, третьей и пятой цифр и сумма второй и четвертой цифр заданного числа.
2. Полученные два числа записываются друг за другом в порядке неубывания (безразделителей) .
Определите, сколько из приведенных ниже чисел могут получиться в результате работы автомата. 40 1030 130 1320 2019 1920 2013 213 3010

В документе 1190 стр. На каждой странице текст расположен в 2 колонки . В каждой колонке 75 строк, а в каждой строке по 65 символов .

Вычислите кол-во информации, содержащейся в документе словаре . Представьте это кол-во в битах, байтах и в производных от них единицах.

Читайте также

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "Даны два различных числа. Составьте программу, которая заменяет наименьшее из двух чисел их суммой, а наибольшее их произведением.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.