Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите написать прогу:

10-11 класс

Разработать алгоритм программы, которая проверяет, является ли введенный с клавиатуры массив убывающей последовательностью чисел.

Помопон35 28 нояб. 2013 г., 5:14:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ekaterina1198
28 нояб. 2013 г., 7:48:35 (10 лет назад)

uses crt;
var i:integer;
a:array[1..100] of real;
begin
writeln('Введите последовательность чисел. 0 - конец последовательности.');
read(a[1]);
i:=2;
while true do
begin
read(a[i]);
if a[i]=0 then
break;
if a[i]>=a[i-1] then
begin
writeln('No.');
halt;
end;
inc(i);
end;
writeln('Yes.');
end.

+ 0 -
Proverner
28 нояб. 2013 г., 8:53:26 (10 лет назад)

Комментарий удален

+ 0 -
ТАТА71
28 нояб. 2013 г., 10:30:14 (10 лет назад)

Да и цикла не нуна: просто каждое новое введенное число в сравнивать с предыдущим - если оно меньше предыдущего, запоминать последнее ( мона сообщать, что последовательность пока еще нужная, убывающая)) и ждать следующего, а если больше или равно, то прекращать работу. обчищать значение переменной и выдавать сообщение, что тока что была последовательность не та, не убывающая). А пока убывает мона сообщать, что последовательность пока еще нужная, убывающая))

Ответить

Другие вопросы из категории

Сколько секунд потребуется модему, передающему сообщение со скорость 28800 бит/сек, чтобы передать 100 страниц текста в 30 сток по 60 символов каждая, при

условии, что каждый символ кодируется одним байтом.
Напишите подробное решение.

Вводится последовательность из N положительных целых чисел. Найти

наименьшее число среди чётных элементов последовательности.

Читайте также

Помогите написать прогу на Паскале!Пожалуйста! Занятия в начальных классах отменяются в тех

случаях, когда температура воздуха не выше –25 градусов, а также при ветре не менее 7 м/с и температуре воздуха не выше –20 градусов. По утренней сводке погоды определить, пойдут ли дети в школу.

Помогите написать прогу в паскале.

дано уравнение
фото внутри

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Помогите написать прогу:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.