Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Написать программу,которая вычисляет дату следующего дня.( Pascal)

5-9 класс

Ниже рекомендуемый вид работы программы.(данные введенные пользователем,выделены жирным шрифтом)

Введите цифрами сегодняшнюю дату(число,месяц,год) 31 12 1998
Последний день месяца!
С наступающим новым годом!
Завтра 1.1.2000

Miraan 17 нояб. 2016 г., 2:36:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nasrulaeva2014
17 нояб. 2016 г., 3:25:43 (7 лет назад)

Паскаль АВС.
Программа вывводит дату следующего дня. Чтоб не утяжелять программу, не стал писать проверку правильности введения даты - то есть пользователь должен вводить только правильные цифры :)

Program Upmixer;
var
  day, month, year:integer;
begin
writeln('Введите дату:');
write('День:'); read (day);
write('Месяц:'); read (month);
write('Год:'); read (year);
day:=day+1;
{если было введено 29 февраля високосного года}
if (((year mod 4)=0) and ((year mod 100)<>0) and (month=2) and (day=30)) then
  begin
    day:=1;
    month:=month+1;
  end;
{если было введено 28 февраля невисокосного года}
if (((year mod 4)<>0) and (month=2) and (day=29)) then
  begin
    day:=1;
    month:=month+1;
  end;
{другие дни}
if ((day=31) and ((month=4) or(month=6) or (month=9) or (month=11))) then
  begin
    day:=1;
    month:=month+1;
  end;
if ((day=32) and ((month=1) or(month=3) or (month=5) or (month=7) or (month=8) or (month=10))) then
begin
    day:=1;
    month:=month+1;
end;
{31 декабря}
if ((day=32) and (month=12)) then
begin
    day:=1;
    month:=1;
    year:=year+1;
end;
writeln('Завтра ', day,' ',month,' ',year);
end.

+ 0 -
Fhbep
17 нояб. 2016 г., 4:10:02 (7 лет назад)

В смысле завтрашнего дня?

+ 0 -
карина1548545
17 нояб. 2016 г., 7:02:50 (7 лет назад)

Пояснение:Какое завтра число

+ 0 -
Maria1476
17 нояб. 2016 г., 10:00:48 (7 лет назад)

Долго в общем прописывать :)

Ответить

Другие вопросы из категории

таня нашла старый калькулятор со стертыми клавишами алгебраических операций сложения,вычитания,умножения и деления(столбец D).Последовательно набрав B2 A2

D4 A3 C1 D3 A2 C3 C4,ОНА ПОЛУЧИЛА 30Какое число получит Таня в результате ,если наберет B3 A1 D1 A3 D4 A3 C2 C4

помогите решить задание, зарание спосибо

1. одна из клавиш меняюшия действие других команд
2. клавиша которая удаляет символ, стояший слева от курсора
3. клавиша для отказа только что выполненого дейсвия
4. клавиша которая удаляет символ стаяший справа от курсора
5. клавиша которая при наборе текста служит для завершения абзаца

помогите решить пожалуйста

Читайте также

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет


Вы находитесь на странице вопроса "Написать программу,которая вычисляет дату следующего дня.( Pascal)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.