Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В кафе продается мороженое по 3 или по 5 шариков в порции. Определить, можно ли купить K шариков мороженного.

5-9 класс

Входные данные:
Во входном потоке в первой строке задано натуральное число К (K <= 1000)

Выходные данные:
Вывести YES или NO.

Пример входного файла (input.txt):
2

201юля 04 февр. 2017 г., 3:31:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Masha5583
04 февр. 2017 г., 4:54:50 (7 лет назад)

   x: - входное число, целое
   а: - целое
шаг 1.
   x - делится на 5 ?
   если да то ответ YES, выход
шаг 2.
   а: = x-5*целое (х/5)
шаг 3
   a - делится на 3 ?
   если да то ответ YES, выход
шаг 4
   a:=a+5
шаг 5
   a - больше чем х ?
   если да то  ответ NО, выход
переход на шаг 3










+ 0 -
муся292821
04 февр. 2017 г., 7:39:55 (7 лет назад)

1. Решение для сомневающихся и привыкших писать программы безмозгло "в лоб"

var
  k, p, q: integer;
  flag: boolean;
  f:Text

begin
  Assign(f,'input.txt');
  Reset(f);
  read(f,k);
  Close(f);
  case k of
    1, 2, 4, 7: writeln('NO');
    3, 5: writeln('YES');
  else
    q := k mod 5;
    if (q = 0) or (k = 3) then writeln('YES')
    else
    begin
      q := (k div 5);
      flag := false;
      while (not flag) and (q > 0) do
      begin
        p := k - 5 * q;
        if p mod 3 = 0 then
        begin
          writeln('YES');
          flag := true
        end;
        q := q - 1
      end;
      if (not flag) then writeln('NO')
    end
  end
end.

2. Решение в соответствии с алгоритмом, приведенным в комментарии к вопросу.

const
  Kno = [1, 2, 4, 7];

var
  k: integer;
  f:Text

begin
  Assign(f,'input.txt');
  Reset(f);
  read(f,k);
  Close(f);
  if k in Kno then writeln('NO')
  else writeln('YES')
end.


+ 0 -
Elizaglubotskaya
04 февр. 2017 г., 8:57:29 (7 лет назад)

Комментарий удален

+ 0 -
Violeetta
04 февр. 2017 г., 10:04:37 (7 лет назад)

нам крупно повезло, что задача сводится к отфильтровке чисел 1 2 4 7
так как в условии задано 3 и 5 шариков
а если бы их было не 3 и 5
а например 11 и 13 или не дай бог еще большие
тогда массив чисел 1 2 4 7 значительно вырос бы
высмеянное Вами решение в лоб легко справится с поставленной задачей
у программистов ведь принято сводить задачу к ранее решенной

+ 0 -
Glebuuus
04 февр. 2017 г., 11:20:35 (7 лет назад)

Комментарий удален

+ 0 -
Reginakisz
04 февр. 2017 г., 13:09:23 (7 лет назад)

Комментарий удален

+ 0 -
Chirkova2003
04 февр. 2017 г., 15:14:08 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

. МЕТЕОРОЛОГИЧЕСКАЯ СТАНЦИЯ ВЕДЕТ НАБЛЮДЕНИЕ ЗА

ВЛАЖНОСТЬЮ ВОЗДУХА. РЕЗУЛЬТАТОТ ОДНОГО ИЗМЕРЕНИЧ ЯВЛЯЕТСЯ ЦЕЛОЕ ЧИСЛО ОТ 0 ДО
100 ПРОЦЕНТОВ, КОТОРОЕ ЗАПИСЫВЕТСЯ ЦЕЛЫМ ЧИСЛОМ БИТ. СТАНЦИЯ СДЕЛАЛА 200 ИЗМЕРЕНИЙ.ОПРЕДЕЛИТЕ ИНФОРМАЦИОННЫЙ ОБЪЕМ
РЕЗУЛЬТАТОВ НАБЛЮДЕНИЯ.

Читайте также

Pascal.

Даны три переменные вещественного типа: A, B, C. Если их значения упо- рядочены по возрастанию или убыванию, то удвоить их; в противном слу- чае заменить значение каждой переменной на противоположное. Вывести новые значения переменных A, B, C.



Вы находитесь на странице вопроса "В кафе продается мороженое по 3 или по 5 шариков в порции. Определить, можно ли купить K шариков мороженного.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.