Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Использовать список при следующем его описании: Type AdrCel=^Element;

10-11 класс

Element=record
Info:integer;
Next:AdrCel;
End;

Составить процедуру, которая удаляет из списка второй элемент, если такой есть.


ХЭЛП МИ

AnyaKotello22 05 июля 2014 г., 14:11:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Moiseeva03
05 июля 2014 г., 14:46:45 (9 лет назад)

type
adrcel=^Element;
Element=record
info:integer;
next:adrcel;
end;
var
start,last,new_el:adrcel;
i:integer;

procedure del2(var start:adrcel);

var

p:adrcel;

begin

p:=start^.next;

if p<>nil then start^.next:=p^.next

end;

begin
start:=nil;
last:=nil;
new_el:=nil;
repeat
new(new_el);
write('info=');
readln(new_el^.info);

new_el^.next:=nil;
if start=nil then
start:=new_el;
else
begin

last:=start;

while last^.next<>nil do last:=last^.next;
last^.next:=new_el;
end;
write('Продолжить? (1-Да/0-Нет):');
readln(i);
until i=0;
writeln('Удалим 2-й элемент');

del2(start);

new_el:=start;
while new_el<>nil do
begin
write(new_el^.info:4);
new_el:=new_el^.next;
end;
readln;
end.

Ответить

Другие вопросы из категории

Для нахождения наибольшего общего делителя двух целых положительных чисел можно применить алгоритм Евклида. Он заключается в следующем: пока

числа не равны, большее число заменяется разностью этих чисел. Полученное в результате число и есть наибольший общий делитель. Какие элементы, пронумерованные от 1 до 5, нужно вставить в блок-схему на места, обозначенные буквами от А до Д, чтобы получившаяся блок-схема соответствовала алгоритму Евклида?

очень срочно.....помогите пожалуйста паскаль

Определить,можно ли сделать круглую заготовку с заданным радиусом R из квадратного листа фанеры с заданной стороной А. решить ее надо с помощью оператора выбора case

Условные

операторы

1 Из трех
данных чисел выбрать наименьшее и наибольшее.

Читайте также

срочно, помогите, хотябы пару пунктов, желательно все((((((! Даны описания: type Oras = (Chisinau, Orhei, Balti, Tigina, Tiraspol);

Zi = (L, Ma, Mi, J, V, S, D);

Consum = array [Oras, Zi] of real;

var C : Consum;

r : Oras;

z : Zi;

Компонента C [r,z] переменной C представляет собой потребление электроэнергии города r в день z. Напишите программу, которая :

а)вычисляет количество электроэнергии, поторебляемой каждым городом за неделю;

б)вычисляет количество электроэнергии, потребляемой данными городами ежедневно;

в) вычисляет город с максимальным еженедельным потреблением электроэнергии;

г) определяет город с минимальным еженедельным потреблением электроэнергии;

д) определяет день, в который было потреблено наибольшее количество электроэнергии;

е) определяет деь с наименьшим потреблением электроэнергии.

Уильям Вингейт предлагает услуги по учету пиццы. Для каждой пиццы он записы-

вает такую информацию:

• Имя компании-производителя пиццы, которое может содержать более одного слова

• Диаметр пиццы

• Вес пиццы

Придумайте
структуру, которая может хранить такую информацию, и напишите
программу, в которой используется переменная специального типа для такой
структуры. Программа должна предлагать пользователю ввести данные для
каждого из названных пунктов и затем выводить эту информацию.
Используйте объекты cin (или его методы) и COUt.

5. Напишите
программу к упражнению 2, но используйте оператор new для выделе­ния
структуре области памяти вместо объявления структурной переменной.
Про­грамма должна также запрашивать диаметр пиццы до запроса названия
компа­нии — производителя пиццы

определить зарплату работнику по больничному листу, проболевшему К дней при следующих условиях, если стаж

работы

до 6 лет – 60%,

от 6-8 – 80%,

более 8 – 100 %,

если несовершеннолетний –100 %,

зарплата работника Z рублей в день.

Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух

последних цифр заданного числа; 3) число, образованное перестановкой второй и четвёртой цифр заданного числа.



Вы находитесь на странице вопроса "Использовать список при следующем его описании: Type AdrCel=^Element;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.