Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найдите сумму чисел четырёхзначного числа.. число 5734..оформить примерно так

5-9 класс

Prodram;
uses crt; и тд.
помогите пожалуйста

Arinakorshik 01 сент. 2014 г., 2:26:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ALEXP2001
01 сент. 2014 г., 3:04:04 (9 лет назад)

Если имеется ввиду сумма цифр
program ads;
uses CRT;
var S,a,b,c,d:integer;
begin
read (S); // Ввод любого 4-ёхзначного числа (5734)
a:=S mod 10;
b:=S div 1000;
c:=(S mod 100) div 10;
d:=(S mod 1000) div 100;
write (a+b+c+d);
end.


Ответить

Другие вопросы из категории

В марафонском забеге участвуют 87 человек. Специальное устройство регистрирует прохождение каждым участником некоторой промежуточной отметки, записывая

его номер с использованием минимального возможного количества бит, одинакового для каждого участника. Каков информационный объём сообщения, записанного устройством, если данную промежуточную отметку миновали только 64 из 87 вышедших на старт участников?
Варианты ответов:
1). 78 байт
2). 78 бит
3). 56 бит
4). 56 байт

Читайте также

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)

1)Ввести 2 числа,заменить число суммой чисел,а большее произведением. 2)Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3)Журнал стоит

k руб.Какую сдачу получит покупатель если у него в руб. 4)Определить ,является ли введенное шестизначное число счастливым,т.е. сумма первых трех цифр числа равна сумме последних трех цифр. 5)Определить ,является число А делителем числа В.

1) Вывести все числа от a до b,но заранее неизвестно, a>b или a<b

2) Вывести нечётные числа из диапозона [a,b],где a и b могут быть как чётными,так и нечётными,а также отрицательными,но обязательно a<b
3) В одной программе посчитать две суммы из [a,b] (те же условия,что и в задании 2)
S-сумма всех нечётных чисел
Sym-сумма чисел,кратных 3
Cами числа выводить не нужно
4)Найти a в степени n,где a и n целые числа, но могут быть отрицательными

(задачи можно делать либо через For,либо через While)

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.



Вы находитесь на странице вопроса "Найдите сумму чисел четырёхзначного числа.. число 5734..оформить примерно так", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.