Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal ABC Помогите с задачей......Задача в файле

10-11 класс

Sylerrr 14 авг. 2014 г., 2:57:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashamihnik21
14 авг. 2014 г., 4:59:42 (9 лет назад)

program D1KPxx5;
uses crt;
var
s:string;
n,k,i,z:integer;
begin
read(s);
k:=1;
n:=length(s);
for i:=1 to n do
begin
if s[i]=' ' then
inc(k);
z:=i;
if k=3 then
break;
end;
while s[z+1]<>' ' do
begin
write(s[z]);            
z:=z+1;
end;
write(s[z]);
end.

+ 0 -
Iluhafun
14 авг. 2014 г., 5:48:31 (9 лет назад)

держи

+ 0 -
Roma1975
14 авг. 2014 г., 7:53:51 (9 лет назад)

Спасибо большое

+ 0 -
Niki0909
14 авг. 2014 г., 10:09:46 (9 лет назад)

всегда пожалуйста))) кстати а чего там за решение было, что его удалили?

+ 0 -
Nafanka
14 авг. 2014 г., 12:11:52 (9 лет назад)

Там не решение, а просто чувак прикольнулся

+ 0 -
Kazanovtim
14 авг. 2014 г., 13:43:08 (9 лет назад)

ахах, ясно)))

Ответить

Другие вопросы из категории

Помогите пожалуйста с информатикой(паскаль)

Посчитать сумму первых 10 чётных чисел.(те которые делятся на 2 без остатка)

1)Вы подошли к светофору, когда горел желтый цвет. После этого загорелся зеленый. Какое количество информации вы при этом получили?

Я ответила, что всего 2 варианта. Оба можно записать 1 битом. Т.о., если я знаю о том, что горит желтый свет, то мне одним битом можно объяснить. что загорелся сигнал "выше желтого", либо "ниже желтого." 2)Вы подошли к светофору, когда горел красный свет. После этого загорелся желтый. Сколько информации вы при этом получили?

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

Здравствуйте. Помогите решить эту задачу в Pascal:

Найти минимальный среди максимальных элементов каждого из столбцов матриц С(5,10) и D(10,20). Задачу решить с использованием подпрограммы.



Вы находитесь на странице вопроса "Pascal ABC Помогите с задачей......Задача в файле", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.