Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите с 3 заданием(паскаль)

10-11 класс

DaniDanzik 31 авг. 2014 г., 7:46:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lidakolesnik
31 авг. 2014 г., 9:08:20 (9 лет назад)

Самая примитивная задача.
Var x1,x2,y1,y2,R1,R2:integer;
Begin
Write('x1='); Readln(x1);
Write('y1='); Readln(y1);
Write('x2='); Readln(x2);
Write('y2='); Readln(y2);
R1:=sqrt(x1*x1+y1*y1);
R2:=sqrt(x2*x2+y2*y2);
If R1>R2 Then Writeln('Точка В находится ближе')
Else Writeln('Точка А находится ближе');
Readln;
End.

+ 0 -
Axmedovagulnar
31 авг. 2014 г., 11:35:47 (9 лет назад)

алгоритм или программу?

+ 0 -
Denda201
31 авг. 2014 г., 12:40:30 (9 лет назад)

программу

Ответить

Другие вопросы из категории

ответить на 2 вопроса более менее кратко

Информационная система:структура управления,
классификация информационных систем

Дана программа на языке Паскаль. Переделать её на язык С++ Var n, i, j, t: integer;

Count, Names: array[1..16] of integer;
Begin
For i := 1 to 16 do
begin
Count[i] := 0;
Names[i] := i;
end;
ReadLn(N); {
Считываем количество голосов}
for i:=1 to N do
begin
ReadLn(t); {
считали очередную пару}
Count[t] := Count[t] + 1;{
подсчитываем её}
end;
{Сортируем массивы
Names и Count в порядке убывания
значений массива
Count}
for i:=16 downto 2 do
for j:=2 to i do if Count[j-1]<Count[j] then
begin
t:=Count[j]; Count[j]:=Count[j-1]; Count[j-1]:=t;
t:=Names[j]; Names[j]:=Names[j-1]; Names[j-1]:=t;
end;
for i:=1 to 16 do
if Count[i] > 0 then
writeLn(Names[i], ' ', Count[i]);
end.

Читайте также

СРОЧНО!!! Помогите пожалуйста с турбо паскаль, задание на тему циклы....

Как мне препод объясняла там должно быть for i:=1 to N do begin
P:P*(2*i)/(2*i+1)
end;
Вот часть которую нужно как то применить к этому заданию...
Как будет выглядеть весь код?)))

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835



Вы находитесь на странице вопроса "помогите с 3 заданием(паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.