Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В заданном массиве к четным элементам прибавить a .

10-11 класс

А из элементов с четным номером вычесть b.

Daniilsh 04 сент. 2014 г., 17:42:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
СуперОксик
04 сент. 2014 г., 20:36:38 (9 лет назад)

const n=5;
var m:array[1..n] of integer;
i,a,b:integer;
begin
readln(a,b);
for i:=1 to n do readln (m[i]);
for i:=1 to n do
if i mod 2 = 0 then m[i]:=m[i]+a
else m[i]:=m[i]+b;
for i:=1 to n do
writeln ('m[', i,']=', m[i]);
end.

Ответить

Другие вопросы из категории

помогите с 3 заданием(паскаль)
ответить на 2 вопроса более менее кратко

Информационная система:структура управления,
классификация информационных систем

Дана программа на языке Паскаль. Переделать её на язык С++ Var n, i, j, t: integer;

Count, Names: array[1..16] of integer;
Begin
For i := 1 to 16 do
begin
Count[i] := 0;
Names[i] := i;
end;
ReadLn(N); {
Считываем количество голосов}
for i:=1 to N do
begin
ReadLn(t); {
считали очередную пару}
Count[t] := Count[t] + 1;{
подсчитываем её}
end;
{Сортируем массивы
Names и Count в порядке убывания
значений массива
Count}
for i:=16 downto 2 do
for j:=2 to i do if Count[j-1]<Count[j] then
begin
t:=Count[j]; Count[j]:=Count[j-1]; Count[j-1]:=t;
t:=Names[j]; Names[j]:=Names[j-1]; Names[j-1]:=t;
end;
for i:=1 to 16 do
if Count[i] > 0 then
writeLn(Names[i], ' ', Count[i]);
end.

Читайте также

Помогите пожалуйста, нужно сделать в паскале, в экселе, и блок-схему!

(задание номер 5 на фото)

Дан одномерный массив А размерностью 16. Определить максимальное значение среди нечетных элементов массива, и минимальное среди четных элементов массива. Получить сумму максимального и минимального значений элементов массива и преобразовать данный массив по принципу из значений нечетных элементов вычесть сумму, а к четным элементам прибавить сумму. Все первоначальные элементы массива вводятся с клавиатуры.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.



Вы находитесь на странице вопроса "В заданном массиве к четным элементам прибавить a .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.