Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В чём ошибка программы? Если не сложно объясните .

10-11 класс

код программы -
Program cikl;
Uses GraphABC;
Var
r:Integer;
begin
for r:=460 downto 100 do
begin
circle(620,480,r);
r:=r-35;
end;
FloodFill(170,480,clPurple);
FloodFill(205,480,clBlue);
FloodFill(240,480,clSkyBlue);
FloodFill(275,480,clGreen);
FloodFill(310,480,clYellow);
FloodFill(345,480,clLime);
FloodFill(380,480,clMoneyGreen);
FloodFill(415,480,clRed);
FloodFill(450,480,clMaroon);
FloodFill(485,480,clBrown);
FloodFill(620,480,clNavy);
End.


Ошибка которую выдаёт программа -
Program1.pas(9) : Нельзя изменять значение переменной цикла внутри этого цикла

Helpme111p 08 сент. 2013 г., 21:47:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinatennis
08 сент. 2013 г., 22:51:01 (10 лет назад)

Ошибка, которую "заметил" компилятор, состоит в нарушении запрета на модификацию параметра цикла For в теле цикла. Для Ваших целей надо было использовать цикл с итерацией, например такой:

  r := 460;
  while r >= 100 do
  begin
    circle(620, 480, r);
    r := r - 35
  end;

В соответствии с алгоритмом, программа должна нарисовать концентрические окружности, центр которых имеет координаты 620;480, а радиус уменьшается от 460 до 100 с шагом 35. После окончания рисования производится заливка различными цветами областей, начальные точки которых указаны своими координатами, а границей области является какая-либо ранее нарисованная линия.
Попробуйте выполнить эту программу...

+ 0 -
Slava0074
09 сент. 2013 г., 0:51:16 (10 лет назад)

Комментарий удален

+ 0 -
Fytktfyz
09 сент. 2013 г., 2:22:31 (10 лет назад)

Комментарий удален

+ 0 -
Chupanovaz
09 сент. 2013 г., 4:44:39 (10 лет назад)

Комментарий удален

+ 0 -
Anzhelatrifonova
09 сент. 2013 г., 7:35:14 (10 лет назад)

Комментарий удален

+ 0 -
Linaragutova
09 сент. 2013 г., 9:54:13 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

В С++ Скажите что не так в этом массиве?

#include <iostream.h>

#include <conio.h>

#include <stdlib.h>

алгоритм должен выводить 0, если нельзя построить треугольник с длинами сторон a,b,c (a,b,c-заданные числа), иначе 3,2,1 если треугольник

соответственно, равносторонний или равнобедренный или другой.

Помогите решить

Вычислить значение логического выражения L при заданных значениях переменных
L=(not(A=1)) and ((a=b) or (a<0)), при A=0, B=1

Читайте также

Есть программа, код приложу,нужно ее переделать используя счетчик.Если не сложно прокомментируйте нововведения.

program pr3;
const a = 2.12;
const b = 7.45;
const h = 0.34;
var x, f1, f2, y, s: real;
begin
x := a;
s := 0;
REPEAT
f1:=3*ln(exp(1/5)*ln(sin(x)+sqr(x)));
f2:=((2*x+1)/(x*x*x*x*x));
y := f1 / f2;
s := s + y;
x := x + h;
UNTIL x > b;
Writeln('S=', s:10:5);
end.

Не сложно, но срочно.

Написать программу для Pascal.
Дано целое число, если оно является положительным, то прибавь к нему 5; в противном случае не изменять его. Вывести полученное число.

Синоптик предсказал погоду следующим образом. Если будет южный ветер или не будет северного ветра, то будет дождливо и не будет холодно. Если

ветра южного не будет, то не будет пасмурно или пойдет дождь. Если все же будет южный ветер, то будет пасмурно, но дождя не будет. Если не будет северного ветра или не будет холодно, то задует южный ветер и будет пасмурно. Какую погоду предсказал синоптик?( Напишите решение, пожалуйста, ответ я и так знаю)

составьте программу которая получает на вход с клавиатуры три неотрицательных целых числа a, b, c,(каждое число с новой строки) и выводит на экран число

1. Если сумма двух каких либо введеных чисел меньше 100. в противном случае, программа должна вывести 0. ничего, кроме число 0 или 1 программа выводить не должна каждое число не превышает 10000



Вы находитесь на странице вопроса "В чём ошибка программы? Если не сложно объясните .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.