Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить приложение на языке паскаль.МОЙ ВАРИАНТ 1 подробнее во вложении

10-11 класс

Sarzhenko 08 янв. 2015 г., 14:27:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leini007
08 янв. 2015 г., 15:21:26 (9 лет назад)

var x,e,xn,xk:real;
i,n,k,fac:integer;
Begin
  read(x);
  fac:=1;
  e:= 0.01;
  for i:= 3 to 6 do begin
    e:=e/10;
    for n:= 1 to 10 do begin
      fac:=fac*n;
      xn:=-1*exp(n*ln(x/2))/fac;
      k:=0;
      repeat
        k:=k+1;
        xk:=xn;
        xn:=xn*exp(2*ln(x/2))/(k+1)/(k+n+1)
      until abs(xk-xn)<e;
      writeln(e:6,'      ',xn:20,'      ',n:2);
    end;
  end;
End.

Ответить

Другие вопросы из категории

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

Составить программу на языке Паскаль

Известна температура больного за 20 дней пребывания в больнице. Можно ли еговыписывать, если для этого требуется, чтобы не менее половины всех дней, когда у негобыла температура ниже 37°, приходилось на вторую половину его пребывания вбольнице?

Составить приложение на языке Pascal.

С помощью ПК произвести обработку одномерного массива, заданного
в таблице. Элементы одномерного массива задать числами в диапазоне
– 20 . . . +50. Необходимо:

описать массив

ввести элементы массива из заданного диапазона;

выполнить с элементами массива действия

вывести результаты на экран.



Вы находитесь на странице вопроса "Составить приложение на языке паскаль.МОЙ ВАРИАНТ 1 подробнее во вложении", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.