Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано n целых чисел. Вывести все числа меньше последнего числа в ряду.

10-11 класс

Opiuma 22 нояб. 2016 г., 7:03:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oksi06101980
22 нояб. 2016 г., 9:22:11 (7 лет назад)

uses crt;
const n = 10;
var a:array [1..n] of integer;
i:integer;
begin
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if (a[i] < a[10]) then
writeln(a[i]);
end.

Ответить

Другие вопросы из категории

Вычислить

(1+sin0.1)(1+sin0.2) ... (1+sin10) для Free Pascal. Помогите!!!!

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.).

Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования. алг

нач

целтаб Dat[1:10]

цел k, m

Dat[1] := 12

Dat[2] := 15

Dat[3] := 17

Dat[4] := 15

Dat[5] := 14

Dat[6] := 12

Dat[7] := 10

Dat[8] := 13

Dat[9] := 14

Dat[10] := 15

m := 0

нц для k от 1 до 10

если Dat[k]>m то

m := Dat[k]

все

кц

вывод m

кон
DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m
Var k, m: integer;

Dat: array[1..10] of integer;

Begin

Dat[1] := 12; Dat[2] := 15;

Dat[3] := 17; Dat[4] := 15;

Dat[5] := 14; Dat[6] := 12;

Dat[7] := 10; Dat[8] := 13;

Dat[9] := 14; Dat[10] := 15;

m := 0;

for k := 1 to 10 do

if Dat[k]>m then

begin

m := Dat[k]

end;

writeln(m);

End.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Дан массив, состоящий из 100 целых чисел:

а) Вывести все числа, которые встречаются в этом массиве по нескольку раз;
б) Вывести все числа, которые встречаются в массиве только по одному разу.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Дано n целых чисел. Вывести все числа меньше последнего числа в ряду.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.