Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите с задачей: это счастливый билет если сумма первых трех цифр равна последним трем. узнать счастливый это билет или нет. p.s. в паскале. СРОЧНО

5-9 класс

НАДО

DжО 08 сент. 2014 г., 15:48:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
19051996
08 сент. 2014 г., 17:38:15 (9 лет назад)

program qq;

uses crt;
var n, s1, s2, a, i, c : integer;
begin
clrscr;
writeln ('vvod');
readln (n);
c:=1;
s1:=0;
s2:=0;
for i:=1 to 3 do
begin
c:=c*10;
a:=(n mod c)div (c div 10);
{отцепление последней цифры и приведение её к разряду единиц}
n:=n-a;
s1:=s1+a;
end;
for i:=1 to 3 do
begin
c:=c*10;
a:=(n mod c)div (c div 10);
n:=(n -a);
s2:=s2+a;
end;
if s1=s2 then writeln ('da')
else writeln ('net');
readkey;
end.

Ответить

Другие вопросы из категории

составьте программу,которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10,затем элементы с четными индексами удваивает, а

элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массивы.

Ребят, очень срочно надо!! Помогите :) Информатика 9 класс)

Ветвление и выбор:
1) Определить min значение из трёх заданных чисел.
2) Определить является ли двух значимое число таким, что сумма цифр его ровна заданному значению а (а=1 до 9)
3) Определить по введенному количеству баллов оценку.
4) Определить кратность введенного трёхзначного числа к 3,через признак делимости на 3.
5) Определить по введенному количеству баллов полученных на экзамен. учебное заведение, в которые может попасть выпускник. max количество баллов 300 не менее 4 учебных заведений.

Хранители памяти.

Приведите примеры:

Читайте также

Определить, счастливый ли билетик.

С помощью 2 массивов. Принцип такой: на билете 6 цифр. Если сумма первых трех будет равна сумме следующих трех, то билет-счастливый.

Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет «счастливым», если сумма первых двух цифр его номера равна сумме

последних двух цифр.
Сколько будет «счастливых» среди всех билетов с четырёхзначными номерами?
Как вы это получили?

1)Ввести 2 числа,заменить число суммой чисел,а большее произведением. 2)Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3)Журнал стоит

k руб.Какую сдачу получит покупатель если у него в руб. 4)Определить ,является ли введенное шестизначное число счастливым,т.е. сумма первых трех цифр числа равна сумме последних трех цифр. 5)Определить ,является число А делителем числа В.

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?



Вы находитесь на странице вопроса "помогите с задачей: это счастливый билет если сумма первых трех цифр равна последним трем. узнать счастливый это билет или нет. p.s. в паскале. СРОЧНО", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.