Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 983 ответов!

дано натуральное число n и последовательность из n натуральных чисел. написать программу определяющую количество положительных членов в

5-9 класс

последовательности

GOODGIRL1234 26 марта 2015 г., 22:36:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fgs78
27 марта 2015 г., 0:52:19 (9 лет назад)

Pascal
var
 mas:array[1..100] of integer;
 sum,n,i:integer;
begin
 readln(n);
 sum:=0;
 for i:=1 to n do
  readln(mas[i]);
 for i:=1 to n do
  if mas[i]>0 then
   sum:=sum+1;
 writeln(sum);
end.

+ 0 -
Ledwat12
27 марта 2015 г., 2:12:35 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Помогите,срочно!!!

Составить программу вывода тех двух значных чисел которые делятся на 9 без остатка

В перечисленных словах необходимо заменить одну букву и получить новое слово,связанное с информатикой и компьютерами:

1)Боль
2)10
3)Вектор
4)Весть
5)Ива
6)Мент
7)Мина
8)Модуль
9)Моль))))))))))

Глупая надежда спрашивать решение..но все же.. 1.Создать массив на 20 значений. 2.Загрузить массив случайными числами от 10 до 100.Как

выразился мой учитель это подсказка: P=INT(RND*90+10)

3.Выполнить сортировку массива по возрастанию.

4.Вывести значение массива в столбик на экран.

Пожалуйста помогите..сегодня весь класс двойки получил...

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Петя загадал последовательность из 4 чисел, в которой каждое следующее число на единицу больше предыдущего. После этого он записал каждое число в

системе счисления с определенным основанием, не меняя порядка чисел. Все числа записаны в системах счисления с разными основаниями. Получилась следующая запись:37 35 33 31Определите, в какой системе счисления записано последнее число, если известно, что одно из чисел записано в восьмеричной системе счисления. В ответе укажите натуральное число, равное основанию этой системы счисления.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

С помощью Паскаля:

1.В магазине продается мастика в ящиках по 15 кг,17 кг,21 кг. Как купить ровно 185 кг мастики, не вскрывая ящики?Сколькими способами можно это сделать?
2.Ввести натуральное число N и вывести все натуральные числа,не превосходящие N и делящиеся на каждую из своих цифр. Пример: Введите N: 15 1 2 3 4 5 6 7 8 9 11 12 15.



Вы находитесь на странице вопроса "дано натуральное число n и последовательность из n натуральных чисел. написать программу определяющую количество положительных членов в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.