Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Помогите составить программу по этой блок схеме

10-11 класс

Chukass 24 июня 2014 г., 13:33:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lianna1811
24 июня 2014 г., 15:58:55 (9 лет назад)

Program asd;
Var x,a:real; 
BEGIN
Write('Введите x: ');
Readln(x);
 a:=x/3+17;
Writeln(a:2:2);
If  odd(Round(a)) = true then a:=(a/2+39)*10
else 
a:=(a+19/2)*5;
Writeln('Результат: ',a:2:2);
END.

+ 0 -
Elina0283
24 июня 2014 г., 17:48:52 (9 лет назад)

Var x:real;
s:real;
Begin
Writeln('Введите x: ');
Readln(x);
s:=x/3+17;
If   not (round(s)) mod 2=0 then
s:=(s/2+39)*10
else
s:=(s+19/2)*5;
Writeln(s);
end.

+ 0 -
Niket23
24 июня 2014 г., 18:49:01 (9 лет назад)

:2 - деление ?

+ 0 -
Alexavdxbbxfa
24 июня 2014 г., 20:20:53 (9 лет назад)

Мало ли ...

+ 0 -
Irinaklimenteva
24 июня 2014 г., 21:40:56 (9 лет назад)

да

Ответить

Другие вопросы из категории

С помощью Паскаля только)
1.Сообщение, записанное буквами из 64-символьного алфавита, содержит 60 символов. Какой объём информации оно несёт?

2. Оцените информационный объём цифровых звуковых файлов длительностью 20 секунд, при глубине кодирования звука 8 бит, частоте дискретизации 8000 измерений в секунду, в режиме моно.

ДАЮ 100 БАЛЛОВ, ТОЛЬКО ПОМОГИТЕ!

Дана вещественная матрица А, размерностью n*m. Найти в каждой строке матрицы максимальный элемент.

Помогите, пожалуйста!

Сократить логические выражения:

Читайте также

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста ))СоставитьПомогите пожалуйста ))Составить программу по которой проверяют является ли элемент массива четным числом.Для записи

"делятся на"использовать стандартную функцию MOD,которая определяет остаток отделение числа А на число В.Примечание таблица R целочисленная.Построение блок-схемы,алгоритм и бейсики.Заранее большое спасибо))

Помогите составить программу для вычисления значения функции y для заданного значения x

у= если x<-3 то
y= √1 - x²
если 1,5<x-3, то
y= в числителе 1 в знаменателе модуль x +2
если x>1,5, то
y=tg x
Составить словесное описание алгоритма, составить блок схему, описать используемые элементы

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.



Вы находитесь на странице вопроса "Помогите составить программу по этой блок схеме", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.