Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу.

5-9 класс

Mar20000444 28 янв. 2017 г., 17:05:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bezzdelniks
28 янв. 2017 г., 18:12:02 (7 лет назад)

var i:word; переменная через которую будут проходить все трехзначные цифры
s:longint; переменная для хранения суммы
begin
s:=0;-обнуляем переменную где будем сохранять сумму
write('Числа: ');
for i:=100 to 999 do  начинаем перебор всех трехзначных цифр
if i mod 2 = 0 then проверка на четность, мод - это деление по остатку,т.е в ответ записывается остаток от деления
if i mod 7 = 0 then begin write(i,' '); s:=s+i; end; выводим четное число кратное 7 и в тоже время суммируем его с последующими четными кратных 7ми, в переменной s
writeln; пропускаем строку
writeln('Сумма всех всех четных трехзначных чисел, которые делятся на 7 = ',s); выводим на экран результат
end.

Ответить

Другие вопросы из категории

Срооооооооооооочнооооооооо!!!!!Помогите пожалуйста!

-Сформировать двумерный массив размером 8*4 из целых чисел ,заполнив случайными значениями в диапазоне от -40 до 90.Определить количество чисел,превышающих среднее арифметическое значение и вывести их на экран
-Сформировать одномерный массив,в котором будут все эти элементы.

Читайте также

Написать программу в турбо паскаль.

Найти сумму всех n-значных чисел (1 ≤ n ≤ 4)

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

1.Найти произведение всех целых чисел от а до 100 (а<100) кратных 17,но не кратных 2 2.Вычислите: 98+96+94+92+90+88+,,,,,+6+4+2

3.Определить и вывести на экран количество трехзначных чисел,которые делятся без остатка на 5 и 21 одновременно.

4.спортсмен пробежал в 1-ый день тренеровки расстояние 10 км. В каждый следующий день он робегал на 3 км больше ,чем в предыдущий. Определить Суммарное расстояние.

5. в Пионерском лагере n отрядов с различным количеством детей. Сколько всего детей в пионерском лагере?

Решите 2 программы. 1) Найдите количество двухзначных чисел, которые делятся на сумму своих цифр. 2) Составьте программу вычисления

количества трехзначных чисел, у которых сумма цифр является чётным числом.

ОЧЕНЬ СРОЧНО!!!



Вы находитесь на странице вопроса "Помогите с Паскалем! Найти сумму всех четных трехзначных чисел которые делятся на 7. Написать программу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.