Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан текст. подсчитать,сколько раз в тексте встречается симьол "+" и сколько раз-симбол "*". удалить эти символы, сдвинув текст. текст отпечатать.

10-11 класс

Elenaprokopeva1 13 нояб. 2016 г., 22:14:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alena030
14 нояб. 2016 г., 0:38:49 (7 лет назад)

var
  s: string;
  i, n1, n2: integer;

begin
  writeln('Введите текст');
  readln(s);
  n1 := 0;
  n2 := 0;
  for i := 1 to length(s) do
    case s[i] of
      '+': n1 := n1 + 1;
      '*': n2 := n2 + 1;
    else write( s[i])
    end;
  writeln;
  writeln('+ удалено ', n1, ', * удалено ', n2)
end.

Тестовое решение:

Введите текст
Y:=35.45*x+2*y/(z-4);
Y:=35.45x2y/(z-4);
+ удалено 1, * удалено 2



+ 0 -
Вячеслав0077
14 нояб. 2016 г., 3:21:53 (7 лет назад)

Комментарий удален

+ 0 -
Sosed201011
14 нояб. 2016 г., 4:18:59 (7 лет назад)

нету ,просто так

+ 0 -
Komaritcina
14 нояб. 2016 г., 6:09:41 (7 лет назад)

Комментарий удален

+ 0 -
Tlieana
14 нояб. 2016 г., 7:34:39 (7 лет назад)

:(

+ 0 -
XuMuKcel
14 нояб. 2016 г., 8:57:28 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

1)Найти

решение уравнения вида kx + b = 0, где k, b - произвольные
постоянные.

2)

помогите пожалуйста срочно
Составить блок-схему и написать на VBA процедуру, организующую ввод с клавиатуры восьми слов, с последующей распечаткой на рабочем листе таблицы по

форме: | Слово | Длина_слова | Начальная_буква_слова | Последняя_буква_слова | Элементы ввода объединить в массив.

Читайте также

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

ПОМОГИТЕ Сделать программу и блок схему ! На Паскале.

Задание:
Определить сколько раз в тексте встречается слово "Давши".
Исходный текст:
Не давши слово-крепись,
А давши - Держись



Вы находитесь на странице вопроса "дан текст. подсчитать,сколько раз в тексте встречается симьол "+" и сколько раз-симбол "*". удалить эти символы, сдвинув текст. текст отпечатать.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.