Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, вычисляющую для двух дробей a/b и c/d (a,b,c,d - натуральные числа):

10-11 класс

деление
умножение
сложение.

Результат представить в виде простых несократимых дробей
В виде функции.
Pascal

Zuhratemirova24 20 окт. 2014 г., 14:21:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelino22729
20 окт. 2014 г., 16:10:42 (9 лет назад)

как-то так)

var a,b,c,d,e,f:integer;
function nod(m,n:integer):integer;
begin
while m<>n do
if m>n then m:=m-n
       else n:=n-m;
nod:=m
end;
begin
write('введите числитель1, знаменатель1, числитель2, знаменатель2');
readln(a,b,c,d);
e:=a*d+b*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('сложение =  ',e) 
      else begin
       e:=e div nod(abs(e),f); 
       f:=f div nod(abs(e),f); 
       writeln('сложение =  ',e,'\',f); 
       end;
e:=a*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('умножение = ',e)
else begin
 e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('умножение =  ',e,'\',f);
         end;
e:=a*d;
f:=b*c;
if f=0 then write('на 0 делить нельзя')
else
         if e=0 then writeln('деление=  ',e)
else begin e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('деление =  ',e,'\',f); 
        end; 
     end.

Ответить

Другие вопросы из категории

Вариант 25

1.а) 66610 б) 30510 в) 15310 г) 16210 д) 24810
2.а) 1347,178 б) 415,248 в) 1345,048 г) 1333,28 д) 643,28
3.а) 113,B16 б) 65,816 в) 155,6C16 г) E5,416 д) 176,716
4.а) 10010102 б) 11002 в) 27608 г)2328 д) 4AC16
ПОМОГИТЕ ОЧЕНЬ СРОЧНО
1. Перевести число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления.
2. Перевести число из восьмеричной системы счисления в двоичную систему счисления.
3. Перевести число из шестнадцатеричной системы счисления в двоичную систему счисления.
4. Перевести число в десятичную систему счисления.

1). Создать в среде MS Excel таблицу со следующими полями:

«Наименование
поставщика», «Юридический адрес», «Телефон», «Факс», «E-mail», «Директор», «Наименование товара», «Единица измерения», «Код по
ОКП», «Номер накладной», «Дата», «Объём поставки», «Цена за единицу», «Общая
стоимость». В поле «Общая стоимость» ввести надлежащие формулы.

Кодирование текстовой, графической и звуковой информации 1) Считая, что каждый символ кодируется одним байтом, определите, чему равен информационный

объем следующего высказывания Жан-Жака Руссо: Тысячи путей ведут к заблуждению, к истине – только один. 1) 92 бита 2) 220 бит 3) 456 бит 4) 512 бит 2) Считая, что каждый символ кодируется 16-ю битами, оцените информационный объем следующей пушкинской фразы в кодировке Unicode: Привычка свыше нам дана: Замена счастию она. 1) 44 бита 2) 704 бита 3) 44 байта 4) 704 байта 3) Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? 1) 16 2) 2 3) 256 4) 1024 4) Разрешение экрана монитора – 1024 х 768 точек, глубина цвета – 16 бит. Каков необходимый объем видеопамяти для данного графического режима? 1) 6 Мбайт 2) 256 байт 3) 4 Кбайта 4) 1,5 Мбайт 5) Производится одноканальная (моно) звукозапись с частотой дискретизации 48 кГц и глубиной кодирования 16 бит. Запись длится 2 минуты, ее результаты записываются в файл, сжатие данных не производится. Какое из приведенных ниже чисел наиболее близко к размеру полученного файла, выраженному в мегабайтах? 1) 11 2) 12 3) 13 4) 20

c решением

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.



Вы находитесь на странице вопроса "Составьте программу, вычисляющую для двух дробей a/b и c/d (a,b,c,d - натуральные числа):", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.