Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму цифр числа (составить прогу с помощью паскаля)

10-11 класс

Olgakrav2013 14 нояб. 2014 г., 12:44:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yaxnoi
14 нояб. 2014 г., 15:19:25 (9 лет назад)

var i,sum:integer;

begin

while i>0 do begin

sum:=sum+(i mod 10);

i:=i div 10;

end;

writeln(sum);

end.

Ответить

Другие вопросы из категории

Организовать процессы шифрования и дешифровки записью семёрок символов текста в обратном порядке. Если длина сообщения не кратна семи, то сообщение перед

шифрованием дополнить словом «корвет» или некоторой его левой частью до получения длины, кратной семи.

Это по JAVE!помогите пожалуйста!

даны катеты прямоугольного треугольника.найти его гипотенузу

Читайте также

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс



Вы находитесь на странице вопроса "Найти сумму цифр числа (составить прогу с помощью паскаля)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.