Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите плиииз! Составьте программу для нахождения среднего арифметического всех натуральных нечетных двузначных чисел.Программа

5-9 класс

выполняется в Паскале!

Orbita 31 марта 2015 г., 1:12:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanya33762
31 марта 2015 г., 2:05:56 (9 лет назад)

var
SrAr:real;
s, i, k:integer;

begin
k:=0;
s:=0;
for i:=10 to 99 do
if i mod 2<>0 then
 begin
 s:=s+i;
 k:=k+1;
 end;
SrAr:=s/k;
writeln(SrAr:5:5);
end.

Ответить

Другие вопросы из категории

как написать рассказ про семью
Определить с помощью утилиты «Установка и

удаление программ», сколько приложений установлено на вашем компьютере, и
вычислить, какое количество информации содержит сообщение о том, что было запущено одно из них.

Читайте также

Оочень срочно, пожалуйста... СоставьтеОочень срочно, пожалуйста... Составте блок-схему и программу для нахождения среднего арифметического всех

натуральных двузначных чисел, кратных 2, в программе- построение блок схем, используя циклический алгоритм

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.



Вы находитесь на странице вопроса "Помогите плиииз! Составьте программу для нахождения среднего арифметического всех натуральных нечетных двузначных чисел.Программа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.