Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста. Дан массив А: array [1..30] of real. Создать программу для нахождения среднего арифметического всех элементов массива. Спасибо)

5-9 класс

Dasha466u 19 нояб. 2014 г., 23:22:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
3919995
20 нояб. 2014 г., 0:20:48 (9 лет назад)

uses crt;
var a:array [1..30] of real; i:integer; sr,s:real;
begin
  clrscr;
  randomize;
  s:=0;
  for i:=1 to 30 do
  begin
    a[i]:=random(100)-50;
    write(a[i],' ');
    s:=s+a[i];
  end;
  sr:=s/30;
  write('sr=',sr);
end.

+ 0 -
Ulinaa
20 нояб. 2014 г., 2:26:00 (9 лет назад)

Массив вводим с клавиатуры или иного устройства ввода.
Создание программы для нахождения среднего арифметического + вывод среднего арифметического на экран.
i - цикловая переменная
sra - среднее арифметическое всех элементов массива
s - сумма всех элементов массива
var
А:array [1..30] of real; 
i:integer;
sra,s:real;
begin
s:=0;
for i:=1 to 30 do
begin
readln (a [ i ]);
s:=s+a[i];
end;
sra:=s/30;
writeln (sra)
end.

Ответить

Другие вопросы из категории

решите пожалуйста срочно надо
Логическая задача: Обманутый продавец

Продавец продает шапку. Стоит она 10 руб. Подходит покупатель, меряет и согласен взять, но у него есть только 25 руб. Продавец отсылает мальчика к соседке разменять эти деньги. Мальчик прибегает и отдает 10+10+5. Продавец отдает шапку и сдачу в 15 руб. Через какое-то время приходит соседка и говорит, что 25 руб. фальшивые, требует отдать ей деньги. Продавец возвращает ей деньги.
На сколько обманули продавца?

Напишите программу на Паскале .

Вычислить сумму всех чисел кратных 3 от 27 до 101 включительно .

Кто изобрёл интернет?

Читайте также

Помогите пожалуйста решить задачи!!!

Задание 1. Составить программу для вычисления по формуле:

Y = √|2x² - 7x| + 12
Задание 2.
Составить программу для вычисления значения функции:
F(x) = \left \{ {{0, If x <=2} \atop {1/(x^{2}+ 6), if x>1 }} \right. {{

Задание 3. Дано натуральное N. Вычислить: S=2*4*6*...*2N.
Задание 4. Дан массив А(20), заполненный датчиком случайных числе. Найти среднее арифметическое всех элементов массива.
Задание 5. дана матрица А(10,10), заполненная датчиком случайных чисел. Найти сумму значений всех элементов данной матрицы.

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Оочень срочно, пожалуйста... СоставьтеОочень срочно, пожалуйста... Составте блок-схему и программу для нахождения среднего арифметического всех

натуральных двузначных чисел, кратных 2, в программе- построение блок схем, используя циклический алгоритм



Вы находитесь на странице вопроса "Помогите пожалуйста. Дан массив А: array [1..30] of real. Создать программу для нахождения среднего арифметического всех элементов массива. Спасибо)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.