Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите сделать подпрограмму с помощью процедуры!!! пожалуйста!!!

10-11 класс

const
CSize1=7;
CSize2=6;
CSize3=5;
type
TMas1=array[1..CSize1,1..CSize1] of integer;
TMas2=array[1..Csize2, 1..CSize2] of integer;
TMas3=array[1..Csize3, 1..CSize3] of integer;
var
A1:TMas1;
A2:TMas2;
A3:TMas3;
i,j,x, y:byte;
function zero(i:integer):boolean;
begin
zero:=false;
if i=0 then zero:=true;
end;
function interval(i:integer):boolean;
begin
interval:=false;if (i<=12) and (i>=1) then interval:=true;
end;
begin
X:=0;
Y:=0;
randomize;
for i:=1 to CSize1 do
begin for j:=1 to CSize1 do
begin A1[i, j]:=random(50);
write(A1[i, j]:3);
if zero(A1[i, j]) then inc(x);
if interval(A1[i,j]) then inc(y);
end;
writeln;
end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
for i:=1 to CSize2 do
begin for j:=1 to CSize2 do
begin A2[i, j]:=random(50);
write(A2[i,j]:3);
if zero(A1[i,j]) then inc(x);
if interval(A2[i,j]) then inc(y);
end;
writeln;
end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
for i:=1 to CSize3 do
begin for j:=1 to CSize3 do
begin A3[i, j]:=random(50);
write(A3[i,j]:3);
if zero(A3[i,j]) then inc(x);
if interval(A3[i,j]) then inc(y);
end;
writeln;
end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
end.

Asz2014 18 июня 2014 г., 2:55:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mado2001
18 июня 2014 г., 4:25:34 (9 лет назад)

const
      CSize1=7;
      CSize2=6;
      CSize3=5;
type TMas=array[,] of integer;   
var
    A1:TMas;
    A2:TMas;
    A3:TMas;
    x, y:byte;

procedure zapoln(var T:TMas;Size:integer);
begin
var i,j:integer;
setlength(T,Size+1,Size+1);
for i:=1 to Size do
  begin
  for j:=1 to Size do
    begin
    T[i,j]:=random(50);
    write(T[i,j]:3);
    end;
  writeln;
  end;
writeln;
end;

function zero(T:TMas):integer;
var i,j,n:integer;
begin
n:=length(T,0)-1;
for i:=1 to n do
  for j:=1 to n do
    if T[i,j]=0 then result:=result+1;
end;

function interval(T:TMas):integer;
var i,j,n:integer;
begin
n:=length(T,0)-1;
for i:=1 to n do
  for j:=1 to n do
    if (1<=T[i,j]) and (T[i,j]<=12) then result:=result+1;
end;

begin
zapoln(A1,CSize1);
zapoln(A2,CSize2);
zapoln(A3,CSize3);
x:=zero(A1)+zero(A2)+zero(A3);
y:=interval(A1)+interval(A2)+interval(A3);
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
end.

+ 0 -
Xysein
18 июня 2014 г., 5:53:12 (9 лет назад)

О чем задача-то?

+ 0 -
BatalovaHelen
18 июня 2014 г., 7:51:56 (9 лет назад)

Дано: массивы А1(N1,M1),A2(N2,M2),A3(N3,M3). Вычислить Х=Х1+Х2+Х3 и Y=Y1+Y2+Y3, где Х1, Х2, Х3-количество нулей в каждом из массивов А1,А2,А3 соответственно, а Y1, Y2, Y3-количество элементов в каждом из двух массивов,лежащих в интервале [1,12]. Определить количество нулей в массиве и кол-во элементов,лежащих в интервале [1,12] и оформить в виде подпрограммы.

+ 0 -
Chuma8696
18 июня 2014 г., 10:31:24 (9 лет назад)

препод сказал в этой подпрограмме всё правильно, только надо объединить в процедуры это...

Ответить

Другие вопросы из категории

Паскаль, задача приложена в изображении 5.55(б), помогите, пожалуйста.

Оператор цикла с параметром.

Срочно!!!Помогите пожалуйста! Всем известно, что «от перестановки слагаемых сумма не изменяется». Однако, случается и так, что перестановка двух чисел

приводит к более интересным последствиям.

Пусть, например, заданы три числа: a1, a2, a3. Рассмотрим равенство a1+ a2= a3. Оно может быть неверным (например, если a1= 1, a2= 4, a3= 3), однако может стать верным, если поменять некоторые числа местами (например, если поменять местами a2 и a3, оно обратится в равенство 1 + 3 = 4).

Ваша задача – по заданным трем числам определить: можно ли их переставить так, чтобы сумма первых двух равнялась третьему.

Входные данные

Входной файл INPUT.TXT содержит три целых числа: a1, a2, a3 (−108 ≤ a1, a2, a3 ≤ 108).

Выходные данные

В выходной файл OUTPUT.TXT выведите слово «YES», если заданные числа можно переставить так, чтобы сумма первых двух равнялась третьему. В противном случае выведите в выходной файл слово «NO».

Опять-таки нужна программа в среде паскаль



На
вход поступает первое число - колличество чисел в
последовательности.Затем вводится последовательность.Подсчитать сумму
чётных чисел больше 30 в последовательности.

Читайте также

Помогите решить в Паскале с процедурой пожалуйста .

Даны
действительные a, b, c, d. Используя функции
поиска максимума двух чисел max и минимума
двух чисел min, получить:
max(a, b)+min(a, b)
+min(c,d)
——————––––—––———
.
max(a, b, c, d) + min(a,b,c)

Очень срооочно!!!Помогите решить подпрограмму в паскале,пожалуйста!!!!!!

Дано:массивы А1(N1,M1),A2(N2,M2),A3(N3,M3). Вычислить Х=Х1+Х2+Х3 и Y1+Y2+Y3, где Х1,Х2,Х3-количество нулей в каждом из массивов А1,А2,А3 соответственно, а Y1,Y2,Y3-количество элементов в каждом из этих массивов,лежащих в интервале [1,12]. Определение количества нулей в массиве и количества элементов, лежащих в этом интервале, оформить в виде подпрограммы.

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.



Вы находитесь на странице вопроса "помогите сделать подпрограмму с помощью процедуры!!! пожалуйста!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.