Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

знайти найменше число елементу масиву з 10(в паскалях)

5-9 класс

будь ласка терміново

Leana04akipa 25 дек. 2016 г., 18:26:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AnastasiaDll
25 дек. 2016 г., 21:10:46 (7 лет назад)

program gt;
var a:array[1..100]of longint;
i,min,n:longint;
begin
randomize;
for i:=1 to 10 do
begin
a[i]:=random(100)-50;
end;
min:=a[1];
for i:=2 to 10 do
begin
if(a[i]<min)then min:=a[i];
end;
write(min);
end.
здесь числа задается случайным набором(компьютером)
2)
program gt;
var a:array[1..100]of longint;
i,min,n:longint;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
min:=a[1];
for i:=2 to n do
begin
if(a[i]<min)then min:=a[i];
end;
write(min);
end.
здесь сначала задаем 10 потом 10 чисел

Ответить

Другие вопросы из категории

квадрат,круг,ромб,треугольник вырезаны из белой,синей,красной и зеленой бумаги.Известно,что круг не белый и не зеленый;синяя фигура лежит между ромбом и

красной фигурой;треугольник не синий и не зеленый; квадрат лежит между треугольник и белой фигурой.Дайте ответы на след. вопросы : 1) Из бумаги какого цвета вырезан квадрат? 2)Из бумаги какого цвета вырезан круг? 3)Из бумаги какого цвета вырезан ромб? 4)Из бумаги какого цвета вырезан треугольник?

Читайте также

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

Играют двое . Первый игрок называет любое число но не выше 10 . Второй прибовляет к названаму числу число не выше 10 и сообщает сумму . 1-й к этой сумме

он прибовляет число но не меньше 10 и т.д. до тех пор , пока ок. Суммой не окажется 100.Выигравает тот , кто первым достигает 100. Как должен действовать первый игрок , чтобы выйграть .

Как на Паскале сравнить два числа N,M<=10^10000;

Вход:N,M<=10^10000;
Выход:Наибольшее число;

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "знайти найменше число елементу масиву з 10(в паскалях)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.