Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

массив К4 содержит 10 элементов вещественного типа-положительных,отрицательных и равных 0.сосчитать количество отрицательных элементов массива и

10-11 класс

вывести сумму их модулей

Dzioeva 29 марта 2017 г., 3:37:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
IRA79
29 марта 2017 г., 4:50:58 (7 лет назад)

var

  K4 : array [1..10] of real;

  sum : real;

  i, count : integer;

begin

  for i := 1 to 10 do read (K4[i]);

  for i := 1 to 10 do

   if k4[i] < 0 then

    begin

      sum := sum - k4[i]; //Т.к. нужен модуль пишем минус

      count:=count+1; 

    end;

  writeln ('Сумма модулей', count, 'отрицательных чисел равна ', sum);

end.

Ответить

Другие вопросы из категории

На

рисунке изображена блок-схема. Какое значение будет присвоено переменной X
после выполнения алгоритма? решите
задачу, решение отразите в отчете

Помогите пожалуйста с паскалем!

В компьюьтер с клавиатуры вводятся 11 целых чисел. Посчитать произведение чисел, кратных 5 и оканчивающихся цифрой 0.

1.Составить блок-схему,которая определяет сумму двузначных четных чисел

2.Составить программу вычисления уравнения : y= \frac{1}{z} + \frac{5}{z-6}
предусматрев вариант,при каких Z, уравнение не имеет решения

Читайте также

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы



Вы находитесь на странице вопроса "массив К4 содержит 10 элементов вещественного типа-положительных,отрицательных и равных 0.сосчитать количество отрицательных элементов массива и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.