Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Программу оформить в паскале) Даны натуральное число n и целые числа . Выяснить, верно ли, что количество тех чисел , которые меньше 20,

1-4 класс

равно пяти.

Karinka100000 24 авг. 2016 г., 21:28:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
100baksov
24 авг. 2016 г., 23:04:07 (7 лет назад)

Program p1;
Var: menee_dvadcati,n,i,x:integer;
Begin

x:=0; //обнуляем x
Readln(n);//считываем n
For i:=1 to n do
Begin
Readln(x);//ввод числа
If x<20 then//проверка (больше 20?)
menee_dvadcati:=menee_dvadcati+1;//считаем количество
end;
If menee_dvadcati>5 then   //проверка (больше 5?)
Writeln('Да') else
Writeln('Нет');
End.

Ответить

Другие вопросы из категории

закончи предложения так, чтобы они: стали суждениями: Исполнитель--------------------------------- Бумага---------------------------------- Звуковая

информация----------------------------- не стали суждениями: Исполнитель--------------------- Бумага----------------------------- Звуковая информация--------------------------

Читайте также

Даны два целых числа - координаты точки в декартовой системе координат. Определить, в какой четверти находится точка.

Входные данные:
Во входном потоке заданы два целых ненулевых числа, значение которых по модулю не превышают 30000.

Выходные данные:
В выходной потов вывести единственное целое число.

Пример входного файла
3 9

На уроці математики Мальвіна запропонувала учням виконати такий алгоритм: 1)Задумай число;2)Додай до числа 1; 3) Помнож результат на 3; 4)Поділи

результат на 3; 5)Відніми від результату 4; 6) Запиши результат. Виконавши завдання, Буратіно отримав число 9, Пєро-число 6, а пудель Артемон-12.Яке число задумав кожний з учнів?

2)Дан фрагмент программы на языке паскаль, на вход которого поданы значения N=10 и M=2. Чему будет равно на выходе из фрагмента значение SUM?

SUM:=0; K :=M-1;

while K<N do

begin

for I(ай) := K-M+2 to K do SUM:=SUM+I;

K:=K+M;

end;

for I:=K-M+2 to N-1 do SUM:=SUM+I;

3)Программист Авсилий Кардов недавно получил банковскую карточку. Чтобы не забыть пароль к карточке, Василий решил построить его по алгоритму, а именно: пароль равен количеству чисел от 1 до 10000, не делящихся на 13 и 17. Чему равен пароль Васи?

4) Какой набор символов будет выведен в результате работы следующей программы?

function f(x:string; a:byte) :string;

begin

if a<=3 then

f:=copy(x, l, a)

else

f:=f(copy (x, 2, a), a-2;

end;

begin

writeln(f('abcdefghijklm',7));

end.

PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в

интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.



Вы находитесь на странице вопроса "Программу оформить в паскале) Даны натуральное число n и целые числа . Выяснить, верно ли, что количество тех чисел , которые меньше 20,", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.