Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль!

10-11 класс

5. Дано трехзначное число. Кратна ли сумма его цифр семи?
8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.

Ludmilk 04 сент. 2014 г., 2:04:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Suluzhan8
04 сент. 2014 г., 4:24:09 (9 лет назад)

8.
var x,y,z,k:integer;
begin
k:=0;
read (x,y,z);
if (x>=1) and (y>=1) and (z>=1) then
begin
if (x<50) then k:=k+1;
if (y<50) then k:=k+1;
if (z<50) then k:=k+1;
writeln (k);
end else
writeln ('Вы ввели не натуральные числа');
end.

Ответить

Другие вопросы из категории

1)Что обозначает слово код-

2)Что обозначает слово кодирование-
3)Что обозначает слов декодирование-

Составьте программу для ввода и вывода температуры за неделю. Результат может быть таким: 1 сентября температура была 17 2

сентября температура была 15

3 сентября температура была 16

4 сентября температура была 19

1) найди последний элемент массива меньше заданного числа

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.