Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом 1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания

5-9 класс

N кг.Язык программирования-паскаль

Kav200882 25 февр. 2014 г., 23:08:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
польчикаавар
26 февр. 2014 г., 1:02:07 (10 лет назад)

var N, a, b: integer;
begin
     readln(N);
     a := N div 5;
     N := N mod 5;
     b := N div 2;
     WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.

Вот так, делением можно)

+ 0 -
Jdisjdh
26 февр. 2014 г., 1:59:13 (10 лет назад)

На каком языке?

+ 0 -
Vfqcd
26 февр. 2014 г., 2:58:25 (10 лет назад)

Паскаль

+ 0 -
Настинио
26 февр. 2014 г., 4:49:43 (10 лет назад)

паскаль я не очень-то шарю

Ответить

Другие вопросы из категории

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

однажды бабушка попросила машу помочь собрать ягоды крыжовника девочка взяла лукошко и подошла к большому колычему кусту она осторожно срывала ягоду

и опускала её в лукошко так маша делала до тех пор пока на кусте не осталось ни 1 ягоды из ягод сварили варенье. запишите действия маши в виде блок схемы !!!!!!!!!помогите!!!!!!!!зарание спасибо огромное!!!!!!!!!

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Составить программу, решающую следующую задачу: Клиент внес

в банк R рублей.
Каждый месяц эта сумма увеличивается на W рублей. Сколько будет у клиента денег через три
месяца?

. Составить программу, решающую следующую задачу:

возраст Коли – X
лет, а возраст Миши – Y
лет. Найти их средний возраст, а также определить, на сколько возраст одного
мальчика отличается от возраста другого.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса ". Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом 1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.