Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пусть

10-11 класс

y0 = 0; yk = (yk-1 + 1)/(yk-1 + 2), k = 1, 2, …
Дано действительное число ε > 0. Найти первый член yn, для которого вы-
полнено yn – yn-1 < ε.
Pascal, помогите решить.

Аllisa 29 мая 2014 г., 10:18:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Раккк
29 мая 2014 г., 11:27:06 (9 лет назад)

var
  y0, yk, yk1, eps, d: double;
  i: integer;

begin
  y0 := 0; yk1 := y0;
  Write('Введите величину погрешности: ');
  Readln(eps);
  repeat
    yk := (yk1 + 1) / (yk1 + 2);
    d := yk - yk1;
    if d >= eps then yk1 := yk
  until d < eps;
  Writeln('yn=', yk)
end.

Тестовое решение:

Введите величину погрешности: 1e-8
yn=0.618033988205325



Ответить

Другие вопросы из категории

Вторая цифра шестнадцатеричного четырехзначного числа равна пяти. Первую цифру переставили в конец числа. Полученное число оказалось на 3F1B(16

cистеме счисления)меньше исходного. Чему равно исходное число, записанное в системе счисления по основанию 16?

помогите пожалуйста,подробное решение. Заранее спасибо

Помогите плиииз=)

Привет. Помогите плиз=)
№1)Составить алгоритм вывода среднего(не арифметического) из трёх чисел в виде блок-схемы.
Входные данные:три числа
Выходные данные:среднее число

№2) На вход подаётся число. Нужно вывести числа от данного до 10. Если оно изначально больше 10, завершить программу.

вычислить через оператор IF

Читайте также

Валентина хочет определить пустой орех в кучке из 729 орехов. Она знает, пустой орех только один и он легче остальных, имеющих одинаковую массу. Валентина

делит все орехи на три равные части с одинаковым числом орехов и взвешивает любые две части на двухчашечных весах. Если вес частей разный, то Валентина узнает, что пустой орех в той группе, которая легче, а если одинаковый, то в той части, которую не клали на весы. Сколько нужно взвешиваний. Чтобы найти пустой орех?
а) 4
б) 5
в) 6

Какие значения чисел:

0.1E + 05, -33.3E - 4, 25.5E + 0?

Запишите по правилам языка Паскаль такие выражения:
a) 1.5 + 2 (x^2 + bx)
b) 3(x + 5) - x^3
_____________
2x^2 + x

Вычислить значения выражений :
a) 125 mod 30
b) 20 div 6 mod 5

Записать выражения в общепринятой форме:
a) (-2*b+3*b-4*a*c)/3*a

Пусть a, b: integer, c: real. Определите тип выражения (целый или вещественный) :
a) a/b
b) a + b
c) a + c

Чему равны значения переменных x и y после выполнения команд: x:=2 ; y:=5 ; y:=x ; x:=x+1?

Решите, пожалуйста, хоть одно какой-нибудь задание. СРОЧНО НУЖНО!



Вы находитесь на странице вопроса "Пусть", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.