Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Треугольник задан длинами своих сторон – a, b, c. Определить является ли

10-11 класс

он тупоугольным, прямоугольным или остроугольным

Сделать разветвляющуюся алгоритмическую структуру.

Danir77 04 авг. 2014 г., 15:04:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
хзб
04 авг. 2014 г., 17:37:36 (9 лет назад)

используем теорему пифагора :) пишу на паскале так как вы не указали нужный вам язык.

 

в решение будет считаться, что cторона с наибольшая

 

var a, b, c : integer;

begin

 

read(a, b, c);


if (sqr(c) = sqr(a) + sqr(b)) then write('primoygolnyi');

if (sqr(c) > sqr(a) + sqr(b)) then write('typoygolnyi');
if (sqr(c) < sqr(a) + sqr(b)) then write('ostroygolnyi');

 

end.

 

+ 0 -
Renat135301
04 авг. 2014 г., 19:49:11 (9 лет назад)

Program Zilly;
uses crt;
const n=10;
var
  a,b,c:real;
  tup,pryam:integer;
begin
 writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  tup:=0;
  pryam:=0;
  writeln('Введите стороны треугольника');
  write('А = '); readln(a);
  write('B = '); readln(b);
  write('C = '); readln(c);
  a:=a*a;
  b:=b*b;
  c:=c*c;
  if a=b+c then pryam:=1;
  if b=a+c then pryam:=1;
  if c=a+b then pryam:=1;
  if a>b+c then tup:=1;
  if b>a+c then tup:=1;
  if c>a+b then tup:=1;
  if tup=1 then writeln('Треугольник тупоугольный')
    else
      if pryam=1 then writeln('Треугольник прямоугольный')
         else writeln('Треугольник остроугольный');
end.

Ответить

Другие вопросы из категории

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5

1)Сколько бит информации несет сообщение о том,что занятия состоятся в одной из 36 аудиторий?

2) Какое число следует за каждым из данных: (а) 667(внизу 8) (б) 101(внизу 2)
3) Выполните арифметические операции: (а)11010110(внизу 2) + 1111001(внизу 2)
(б) 1110(внизу 2) * 1001(внизу 2) (в) 1100011(внизу 2) - 11111(внизу 2)

Метод защиты информации, включающий в себя функции регистрации обращений к защищаемым ресурсам и реагирование:

1) побуждение

2) препятствие

3) маскировка

4) принуждение

5) управление доступом

Пусть

y0 = 0; yk = (yk-1 + 1)/(yk-1 + 2), k = 1, 2, …
Дано действительное число ε > 0. Найти первый член yn, для которого вы-
полнено yn – yn-1 < ε.
Pascal, помогите решить.

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Даны три стороны треугольника .определить существует ли треугольник с заданными сторонами,если да ,то определить является ли он

прямоугольным,равнобедренным или равносторонним,какой треугольник тупоугольный или остроугольный.

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)



Вы находитесь на странице вопроса "Треугольник задан длинами своих сторон – a, b, c. Определить является ли", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.