Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)(паскаль) Дан

10-11 класс

целочисленный массив из 30 элементов. Элементы массива могут принимать целые
значения от 0 до 100 – баллы учащихся выпускного класса за итоговый тест по
информатике. Напишите программу, которая находит и выводит номера двух соседних
элементов массива, сумма которых минимальна. Исходные данные объявлены так, как
показано ниже. Запрещается использовать переменные, не описанные ниже, но
разрешается не использовать часть из них.

ElenaLs 28 нояб. 2016 г., 21:35:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SerzHxXX
28 нояб. 2016 г., 23:53:50 (7 лет назад)

Использовал две переменные из пяти возможных.

const N=30;
var a: array [1..N] of integer;
i,j:integer;
begin
for i:=1 to N do read(a[i]);
j:=1;
for i:=1 to N-1 do if a[i]+a[i+1]<a[j]+a[j+1] then j:=i;
write(j,' ',j+1)
end.

Ответить

Другие вопросы из категории

Сколько бит содержит 2 Кбайт?
Помогите пожалуйста.

По этой функции нужно составить программу в
Паскале!
Ничего не понимаю...

Винтик поставил на скачивание файл и определил, что закачка займет 20 мин. Через 4 минуты на этом же компьютере Шпунтик поставил на скачивание свой файл.

После того как файлы были скачены, выяснилось, что объем файла Шпунтика на 20% больше файла Винтика. При скачивании двух файлов скорость скачивания каждого в два раза ниже первоначальной, при скачивании одного- равна первоначальной. С какой разницей в минутах закончилось скачивание файлов?

Читайте также

задания по паскалю Даны координаты двух различных полей шахматной доски х1, y1, x2, y2 (целые числа, лежащие в диапазоне 1-8). Проверить

истинность высказывания: «Данные поля имеют одинаковый цвет».

помагите решить

Помогите решить задачу в паскале.Дана

строка символов р1, р2,
..., рn. Определить число вхождений в последовательность группы
букв "xyz". Вырезать
фрагмент из текста между первым и вторым вхождением группы символов "xyz".

ДАМ 22 ПУНКТА СРОЧНО

СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ
данны два числа a и b.составить программу для вычисления среднего арифметического кубоы этих чисел



Вы находитесь на странице вопроса "1)(паскаль) Дан", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.