Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В чем ошибка? Найдите пожалуйста

5-9 класс

Podbereznayana 16 апр. 2013 г., 9:39:15 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Galinabarinova
16 апр. 2013 г., 11:12:09 (11 лет назад)

там надо убрать else  и одну строчку K:=M div W;

+ 0 -
Droniakira
16 апр. 2013 г., 13:43:29 (11 лет назад)

Скорее всего, исходный текст такой:

program sdf;

var
  M, W, A, K, N: integer;

begin
  writeln('Введите кол-во дней в месяце');
  readln(M);
  writeln('Введите кол-во недель');
  readln(W);
  if (M = 30) or (M = 2) and (W = 7) or (M = 10) then
  begin
    K := M div W;
    A := M div W;
    N := A + 1;
  end
  else
    K := M div W;
  writeln(K, N);
end.

+ 0 -
алинчик20072002
16 апр. 2013 г., 14:34:42 (11 лет назад)

А где текст или что у вас?

+ 0 -
Вика0905
16 апр. 2013 г., 16:00:36 (11 лет назад)

program sdf;
var M, W, A, K, N : integer;
begin
writeln ('Введите кол-во дней в месяце');
readln (M);
writeln ('Введите кол-во недель');
readln (W);
If (M=30) or (M=2) and (W=7) or (M=10) then
K:=M div W;
A:=M div W;
N:=A+1;
else
K:=M div W;
writeln (K, N);
end.

+ 0 -
поля2014
16 апр. 2013 г., 16:33:29 (11 лет назад)

где else пишет ожидался оператор

+ 0 -
Innochkapoliak
16 апр. 2013 г., 17:11:22 (11 лет назад)

что за

Ответить

Другие вопросы из категории

Информатика, логика, 9 класс, помогите! Сколько различных решений имеет уравнение (K/\L/\M)\/(¬L/\¬M/\N) = 1 где K, L, M, N - логические переменные? В

ответе не нужно перечислять все различные наборы значений K, L, M и N, при которых выполнено данное равенство. В качестве ответа нужно указать только количество таких наборов.

Помогите пожалуйста!!

Единица товара стоит a рублей

Читайте также

Исправьте ошибки, ПОЖАЛУЙСТА!!!

Кузнец подковал лошадь. В каждой подкове 6 гвоздей. Владельцу было предложено два вида оплаты:
1) заплатить за все гвозди 50 рублей.
2) За 1 гвоздь - 1 коп., 2 гвоздь - 2 коп., и т.д. каждый раз в два раза больше чем за предыдущий гвоздь.
Владелец предпочёл второй вариант. Во сколько раз больше он заплатил?

Короче, вот программа, но она не работает.
Ошибки исправьте, пожалуйста.

В чем ошибка? Найдите пожалуйста
вывести на экран номер всех счастливых билетов и подсчитать сколько их? В чем ошибка?

var a,b,c,d,f,e,n:longint; k:real;begink:=0;for n:=000001 to 999999 do begin a:= n mod 10;b:= n div 10 mod 10;c:= n div 100 mod 10;d:= n div 1000 mod 10;f:= n div 10000 mod 10;e:= n div 100000 mod 10;if(a+b+c=d+f+e) then begin writeln(n);k:=k+1;end;end;end.
покупатель должен заплатить в кассу S рублей . У него есть купюры в 1,2,5,10,50,100,500 руб. Найти наименьшее кол-во , которым он может рассчитаться? Помогите пожалуйста!

найдите пожалуйста ошибку(система паскаль) задача: даны два числа. вывести больше

е из них.

program zadacha6;

var a,b: real;

begin

readln(a,b);

if a>b then writeln ( ' a bolshe ' ) else writeln ( ' a menshee ' );

end.

ПОМОГИТЕ В ЧЕМ ОШИБКА!!

program ZADACHA1;

var
a,b,c,d,d1,e:integer;
x,y,k,l:real;

begin
WRITELN('Цыбулак Максим');
READLN(a);
READLN(b);
c:=a+b;
e:=a*b;
d:=a-b;
k:=a/b;
d1:=b-a;
l:=b/a;
WRITELN('a+b=',c);
WRITELN('a-b=',d);
WRITELN('b-a=',d1);
WRITELN('a*b=',e);
WRITELN('a/b=',k);
WRITELN('b/a=',l);
m;=SQR(a);
n;=SQR(b);
o;=SQRT(a);
p;=SQRT(b);
WRITELN('квадрат числа',a,'=',m);
WRITELN('квадрат числа',b,'=',n);
WRITELN('корень числа',a,'=',o);
WRITELN('корень числа',b,'=',p);
end.



Вы находитесь на странице вопроса "В чем ошибка? Найдите пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.